Unable to deploy forms in Central with error formID missing

Hi kind Central folks. Hopefully someone has an easy explanation for this.

1. What is the problem?
I'm unable to deploy forms in Central. The error is Required parameter formId missing.

2. What app or server are you using and on what device and operating system? Include version numbers.
Tried on the ODK sandbox server and on a fresh Docker installation on DigitalOcean (currently running 85f7164).

3. What you have you tried to fix the problem?

Tried various XLS forms, all valid, including with and without settings sheet and form_id column. Confirmed that forms were valid on https://opendatakit.org/xlsform/.

4. What steps can we take to reproduce the problem?

  1. Create new project
  2. Add new form, select file, click Create

5. Anything else we should know or have?

Raw server response:

message: "Required parameter formId missing.", code: 400.2, details: {field: "formId"}}
code: 400.2
details: {field: "formId"}
message: "Required parameter formId missing."

Error in UI:

Test form: testform.xlsx (43.3 KB)
Project on Central sandbox: https://sandbox.central.opendatakit.org/#/projects/27

Native XLSForm support is not yet available so you will need to convert your form to XML first!

@issa How about sending back a more helpful error message in the sure-to-be-common case that the provided file fails existing checks and also happens to have a .xls or .xlsx extension?

hm. this is a bug/regression. it's supposed to never even allow that file to be uploaded. @Matthew_White ?

I don't think I ever set up Frontend to check for .xls/.xlsx upload, but I agree that that would be useful. I think we've talked about having Central support XLSForms in the near future. Would it be worth adding this check for the upcoming v6 release if we might remove it in v7?

Thanks @LN, I didn't realize that. In retrospect I see that the instruction clearly requires an XML, not XLSForm. Merci!

1 Like