Unable to download submission from ODK Central

1. What is the problem? Be very detailed.
I've just installed the ODK Central 1.1.1 on Ubuntu 20.04 VM on Windows 10 host as a local server.
It's a fresh install using Docker compose on Ubuntu following the Installing Central on DigitalOcean — ODK Docs

The form was published on HTTPS public domain, and successfully submitting data from mobile devices.

But the CSV and zip file submission download end up with error 403.1, even with the administrator account.

"{"message":"The authenticated actor does not have rights to perform that action.","code":403.1}"

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Central 1.1.1 on Ubuntun 20.04 LTS VM on Windows 10 host

4. What steps can we take to reproduce the problem?
Click the download submission button.

1 Like

Hi @Supharerk_Thawillarp!

Linking here to our discussion on GitHub. Thanks for posting to the forum!

You wrote on GitHub that filling a Submission using Enketo worked even though downloading Submissions doesn't. How do you access Enketo to fill a Submission? Do you use Public Access Links or the "Fill Form" button in the Form table or the "New" button on the Submissions page?

In addition to Submission download, there is other functionality within ODK Central that uses cookie-based authentication. Could you say whether the following works for you? (If not, what happens?)

  • Previewing a published Form using Enketo (on the Form Overview page)
  • Downloading a Form Definition (on the Form Overview page)

I generated the public access link and fill the form using the link. It works fine.

However, the "New" button did not works, it keep redirecting me back to the login page indefinitely.

  • Preview button also keep redirecting me back to the login page. I filled the user/pass several time but did not get through.

  • Downloading a Form Definition failed "Couldn't download - No Permission "

It sounds like functionality that uses cookie-based authentication (including the "New" button) isn't working across the board. Public Access Links don't use cookie-based authentication, which I think is why the link works.

Cookie-based authentication only works over HTTPS, but you wrote on GitHub that you are using HTTPS. What browser are you using? Are you using a proxy server?

Yes, it's a public domain-name with https. My browser is a Microsoft Edge 87.0.664.66 on Windows 10 with no proxy server.

1 Like

You're using the latest version of Edge, so cookie-based authentication is expected to work. I just tried cookie-based functionality in this version of Edge and didn't encounter any issues.

It'd be useful to see what your cookie settings are in Edge. Under settings, navigate to Cookies and Site Permissions, then "Cookies and site data". What are your settings there?

You might also want to try creating a new profile in Edge or testing whether things work in another browser.

2 Likes

I tried switching to Chrome v87 and everything works well (previewing,Downing the form XML, New submission button, Downloading the submission etc.).

So I think the problem is in my browser setting.

This is the setting in Edge.

Ok I created a new Edge profile, and everything is working. Browsing as guest also works for both Chrome and Edge.

To sum up, the problem is my browser's setting not the ODK central.

If anyone encounter this problem, create a new browser profile, reset the setting or switch to incognito mode works .

@Matthew_White Thank you for your help :slight_smile:

2 Likes

I'm glad that worked! Your settings look normal to me, so I'm not sure what the issue was. Do you use browser extensions? Could one have been blocking the cookie?