Unable to install ODK Aggregate because of Error 400

1. What is the problem? Be very detailed.
I was trying to install ODK Aggregate using token. I'm able to establish the OAuth service account. Java is installed in my Windows 10 laptop and when I use token fetched from incognito browser, it is throwing error (attachment 1).

Later, I tried going ahead by using shell after watching a youtube video but there also some files are throwing error (attachment 2).

2. What app or server are you using and on what device and operating system? Include version numbers.
OS: Windows 10
Project is created on Google Cloud Platform
Aggregate: 1.7.4
Java: 15

3. What you have you tried to fix the problem?
I tried using incognito, followed all the steps as is from ODK support portal (https://docs.getodk.org/aggregate-app-engine/#download-aggregate-installer)

I also created the project and set up the OAuth service account following (https://docs.getodk.org/oauth2-service/) successfully.

4. What steps can we take to reproduce the problem?

  1. Create account and project on Google Cloud Platform where project’s App Engine will store data and execute
  2. Download ODK Aggregate Application using installer (https://github.com/getodk/aggregate/releases/tag/v1.7.2) or (ODK Aggregate v1.7)
    a. Launch the *.exe file downloaded from mentioned links
    b. Accept the terms and condition
    c. Select folder as directory and Google App Engine as option to run the ODK Aggregate
    d. Provide instance name as project name used in Google Cloud Platform (Use organization name in instance name as it helps users to identify)
    e. Set Superuser name, you may use the same name as project name or similar
    f. Enter application ID created on Google Cloud Platform as project ID under console with the current project on top of the window
    g. Personal email ID or a google account to get token
    h. Pop up will open and click on “allow”, copy the code given by browser
    i. When you click “ok” after entering the code, a console will be visible and after a while it shows this error message "400 Bad Request". Kindly refer to the attachment 1.

Later I tried steps mentioned in the video to install ODK aggregate using Shell. I followed the instructions and used these commands
gcloud app deploy service-name-app.yaml
gcloud app deploy app.flexible.yaml

and it threw error both the times that the file these commands is looking for does not exist. Kindly refer the screenshot 2.

Please help me install ODK aggregate as we are a not for profit organization working with farmers in India. ODK is the best open-source tool which can help us collect data with low or no network zones. We tried Google forms but failed as this geography doesn't support online data collection well.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @anchalanshrid
We're glad you're here. When you get a chance, please introduce yourself on this forum thread.

Deployments using appcfg are no longer supported.

That means you won't be able to upload this particular version on Google Cloud (Aggregate v1.7.4).

Why did you choose an old version of Aggregate?
Are you aware that we no longer work on ODK Aggregate and ODK Central is our new, recommended server?

I wasn't aware of the newer version. Let me try with ODK Central. Will the remaining steps remain same or change for ODK Central?

The steps will be different since it's a completely separate project.
Please notice that you don't even need to install it on your own, you can choose ODK Cloud.

As far as I know ODK Cloud is paid, whereas Aggregate was not. Right?

ODK Cloud is a paid service you are right. If you choose it you don't need to worry about the infrastructure and installation. It uses ODK Central which is a recommended server.
ODK Central like ODK Aggregate is free you can install it on your own.
ODK Cloud is paid because you pay for the service and support.

1 Like

OK got it, thanks. Let me try the ODK Central once.