Unable to login after Upgrading Central Server from v1.3 to v1.5

1. What is the issue? Please be detailed.
I was upgrading my ODK Central from v1.3 to the latest one
(versions:
da62679fe138eb89b42fcc2d9f61ae9beca9d67b (v1.5.3-2-gda62679)
d9cb07fdceaa7df017ed2aee114db1b2b7e1a2d8 client (v1.5.3)
badb3912fdf4d5dca29bd4cd520b9d3b4788db6e server (v1.5.3))
from the this thread. Every command run on my putty and I got output accordingly.
While I was checking system with the help of sudo docker-compose ps, I found this

However, When I am trying to log-in into the server. It is saying that "THE USER IS ALREADY LOGGED IN. PLEASE REFRESH THE PAGE".

When I checked stats of my CPU, that is also good. Here is the screenshot:

When I run "docker logs --tail 100 central_service_1" , I get this output

My infrastructure is on AWS. I am using t3a.large with 8GB RAM.

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?
Reboot server, and allocate memory. Severe issue on multiple Central working with images - Error 500 - #4 by yanokwa
I think that I am missing something on this thread. But I do not know what I am missing,

4. Upload any test forms or screenshots below.

Central is running complex migrations and since you are on a relatively slow and burstable instance, the migration is taking a very long time. Roughly how many submissions do you have?

I'd probably temporarily resize to a bigger machine like a m5.xlarge, allocate 8 GB to Central, and it should go a lot faster.

Thanks @yanokwa,

After following your instructions, I am getting same error and unable to login.

wait-for-it.sh: postgres:5432 is available after 0 seconds
generating local service configuration..
running migrations..

Above are logs.
and below is stats.

Is this possible that If I will remove code for PostgreSQL and after that I will build my docker. Than I am able to use. I found this post.

Will it work if I am not using PostgreSQL ?

Best,
Narendra Singh
@iamnarendrasingh

Hi,

I am facing almost the same issue.

Upgraded Central from v1.3.2 to v1.5.3, and now it is not letting me log in. Same specs infrastructure on AWS.

What to do?

For how long have you been facing this issue?

It seems to have been resolved. I did upgrade of 2 servers, and in the light of yaw's advice, after docker service restart, I left the server idle for 10 minutes (did not try to login through browser), in order for the backend scripts to run. And it was perfectly fine when I logged in.

Just to confirm: I did not change anything additional other than running the upgrade process.

1 Like

I checked my ping request text file and find out that it took 6 hours to migrate not 10 minutes. In my case, I am sure it also depends that how much data do you have on server as well.

Best,
@iamnarendrasingh

1 Like

My real data was around 50GB. For some odd reason, it was bloated to be 250GB before the upgrade and choked my disk (I had to expand the disk); but after the upgrade, it came back to 50GB. Perhaps the unnecessary data was cleaned up as part of optimization during the upgrade.

Server: t3.large

1 Like