Unable to upload ODK record to server

1. What is the problem? Be very detailed.
Justa after the ODK Collect version upgrade to 1.23.0 some forms started to fail sending the message on collect: Error generic Exception: Unexpected char 0xf3 at 58 in Content-Disposition value: form-data; name="xml_submision_file";filename="COM Reunioón de Recuperación_2019-08-02_15-05-05.xml". The clients with the previous version 1.22.4 still sending the records with no problem.
2. What app or server are you using and on what device and operating system? Include version numbers.
Aggregate version 1.4.15 on Google Cloud Platform java8, api version 1.0 deployed on oct,4, 2018 App Engine
3. What you have you tried to fix the problem?
I tryed to reinstall collect, download form, but always is sending the same error
I will try to upgrade Aggregate then

4. What steps can we take to reproduce the problem?
Use my form, first in your server, then on my aggregate to reproduce the error

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
ReunionRecuperacion.xlsx (17.3 KB) ReunionRecuperacion.xml (5.3 KB) ErrorScreen

1 Like

Thanks so much for that quick and detailed report, @Fruisenor. I see what the issue is and will try to get a fix out as soon as possible.

This issue has been fixed in Collect v1.23.1 and it's being rolled out to all devices on the Play Store. You should have it in a few hours.

1 Like

Thank you very much for your great support. I will inform as soon as I got the 1.23.1 working. :slight_smile:


Collect V1.23.1 works perfect. Thank you very much!

1 Like