Upgrading ODK Central from 1.2 to 1.5 - docker-compose up error

I have updated an old server which was still running ODK Central 1.2
For this, I first updated docker-compose (1.22.0 to the newest 2.12.2).

After running docker-compose build and docker image prune, when I run docker-compose stop I get the following output:

:~/central# docker-compose stop
[+] Running 9/0
⠿ Container central_nginx_1 Stopped 0.0s
⠿ Container central_service_1 Stopped 0.0s
⠿ Container 46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_central_enketo_1 Stopped 0.0s
⠿ Container central-postgres-1 Stopped 0.0s
⠿ Container central-mail-1 Stopped 0.0s
⠿ Container central-pyxform-1 Stopped 0.0s
⠿ Container central-enketo_redis_cache-1 Stopped 0.0s
⠿ Container central-secrets-1 Stopped 0.0s
⠿ Container central-enketo_redis_main-1 Stopped 0.0s

The container
central_enketo_1
has been replaced by 46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_central_enketo_1

Then, docker-compose up does not work, and it gives the error:
Running 0/0
⠋ Container 46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_46049b062660_central_enketo_1 Recreate 0.0s
Error response from daemon: No command specified

Thank you for your support!

Did you run:
docker-compose up
or:
docker-compose up -d
?

I run
docker-compose up -d
first, but then also tried without -d.

Now I removed the images and recreated them. I also tried to pull version 1.3 and rebuild, but did not succeed.
docker-compose build seems to work but then I get

$docker-compose up
[+] Running 4/0
 ⠿ Container central-postgres-1              Created                                                                                                                                                          0.0s
 ⠋ Container 8ef3d8705f96_central-pyxform-1  Recreate                                                                                                                                                         0.0s
 ⠿ Container central-enketo_redis_main-1     Created                                                                                                                                                          0.0s
 ⠿ Container central-enketo_redis_cache-1    Created                                                                                                                                                          0.0s
 ⠿ Container central-mail-1                  Created                                                                                                                                                          0.0s
 ⠋ Container central-enketo-1                Creating     
Error response from daemon: No command specified

Should I go back to the 1.2 and to the previous docker-compose version?

Run docker --version and docker-compose --version and report back what you find. This is what I expect.

$ ~/central# docker --version
Docker version 20.10.18, build b40c2f6

$ ~/central# docker-compose --version
docker-compose version 1.29.2, build 5becea4c
2 Likes

I have the following:

docker --version
Docker version 19.03.1, build 74b1e89

# docker-compose --version
Docker Compose version v2.12.2

should I try updating docker and downgrading docker-compose as suggested?

Thanks!

1 Like

Yes, I'd try updating docker to v20.10.x. My guess is that's the problem.

Try installing docker-compose v1.29 as shown below.

sudo curl -L "https://github.com/docker/compose/releases/download/1.29.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose
sudo ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose