Upload from Android to aggregate VM

Hi all, I have downloaded the ODK aggregate VM and it seems to be working
fine, I can get to it from the desktop as well as a phone using a browser.
I have used XLSform to create a form and loaded that onto the phone, and
the survey seems to run fine. In the "settings" tab of the xls file used to
generate the form I have entered the form_title and form_id, deleted the
public_key in the sample xls file, and entered the URL of the VM as

http://nnn.nnn.nnn.nnn/

When I try to "send selected" I get the error

Error: Invalid status code on Head request. If you have a web proxy, you
may need to login to your network.

Any ideas what I'm doing wrong?

Thanks,

Oops, following the example, I now used for the submission_url

http://nnn.nnn.nnn.nnn/submission/

and get the error

Error: Not Found (404) at http://nnn.nnn.nnn.nnn/submission?deviceID=imei%
(a string of numbers presumably identifying the phone)

So I think I'm closer but still no go.

I should also mention that I have checked all boxes for the username in the
Site Admin tab of the VM's web page.

··· On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote: > > Hi all, I have downloaded the ODK aggregate VM and it seems to be working > fine, I can get to it from the desktop as well as a phone using a browser. > I have used XLSform to create a form and loaded that onto the phone, and > the survey seems to run fine. In the "settings" tab of the xls file used to > generate the form I have entered the form_title and form_id, deleted the > public_key in the sample xls file, and entered the URL of the VM as > > http://nnn.nnn.nnn.nnn/ > > When I try to "send selected" I get the error > > Error: Invalid status code on Head request. If you have a web proxy, you > may need to login to your network. > > Any ideas what I'm doing wrong? > > Thanks, >

Phil,

What version of ODK Collect are you using? Try removing the
submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in
ODK Collect's settings as the URL, and put the username and password
there as well. Does that work better?

Yaw

··· -- Need more help? Go to http://nafundi.com for custom development, professional support, form design, implementation advice, and user training for ODK.

On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz phurvitz@gmail.com wrote:

Oops, following the example, I now used for the submission_url

http://nnn.nnn.nnn.nnn/submission/

and get the error

Error: Not Found (404) at http://nnn.nnn.nnn.nnn/submission?deviceID=imei%
(a string of numbers presumably identifying the phone)

So I think I'm closer but still no go.

I should also mention that I have checked all boxes for the username in the
Site Admin tab of the VM's web page.

On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote:

Hi all, I have downloaded the ODK aggregate VM and it seems to be working
fine, I can get to it from the desktop as well as a phone using a browser. I
have used XLSform to create a form and loaded that onto the phone, and the
survey seems to run fine. In the "settings" tab of the xls file used to
generate the form I have entered the form_title and form_id, deleted the
public_key in the sample xls file, and entered the URL of the VM as

http://nnn.nnn.nnn.nnn/

When I try to "send selected" I get the error

Error: Invalid status code on Head request. If you have a web proxy, you
may need to login to your network.

Any ideas what I'm doing wrong?

Thanks,

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Yaw, thanks for the reply.

I am using version collect 1.2.2 (1023) on a Motorola Atrix.

I removed text from the public_key and submission_url fields in the xls
file, and verified that the xml form I have on the phone is recent (by
adding a note).

When I try sending the form, the "Server Requires Authenitcation" popup
shows the URL as

http://n.n.n.n/submission?deviceID=imeai%3....

and I used the default passwords in the collect settings as I did for the
Configure Site Access in the web page for the VM.

I'm still getting 404--it seems to me the web server is having problems
with the "/submission?..." part of the URL.

··· On Saturday, February 9, 2013 8:55:31 AM UTC-8, Yaw Anokwa wrote: > > Phil, > > What version of ODK Collect are you using? Try removing the > submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in > ODK Collect's settings as the URL, and put the username and password > there as well. Does that work better? > > Yaw > -- > Need more help? Go to http://nafundi.com for custom development, > professional support, form design, implementation advice, and user > training for ODK. > > On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz <phur...@gmail.com> wrote: > > Oops, following the example, I now used for the submission_url > > > > http://nnn.nnn.nnn.nnn/submission/ > > > > and get the error > > > > Error: Not Found (404) at > http://nnn.nnn.nnn.nnn/submission?deviceID=imei% > > (a string of numbers presumably identifying the phone) > > > > So I think I'm closer but still no go. > > > > I should also mention that I have checked all boxes for the username in > the > > Site Admin tab of the VM's web page. > > > > > > On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote: > >> > >> Hi all, I have downloaded the ODK aggregate VM and it seems to be > working > >> fine, I can get to it from the desktop as well as a phone using a > browser. I > >> have used XLSform to create a form and loaded that onto the phone, and > the > >> survey seems to run fine. In the "settings" tab of the xls file used to > >> generate the form I have entered the form_title and form_id, deleted > the > >> public_key in the sample xls file, and entered the URL of the VM as > >> > >> http://nnn.nnn.nnn.nnn/ > >> > >> When I try to "send selected" I get the error > >> > >> Error: Invalid status code on Head request. If you have a web proxy, > you > >> may need to login to your network. > >> > >> Any ideas what I'm doing wrong? > >> > >> Thanks, > > > > -- > > You received this message because you are subscribed to the Google > Groups > > "ODK Developers" group. > > To unsubscribe from this group and stop receiving emails from it, send > an > > email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/groups/opt_out. > > > > >

Or maybe it is because I have these in my "survey" tab?

start end today deviceid subscriberid

··· On Monday, February 11, 2013 11:32:08 AM UTC-8, Phil Hurvitz wrote: > > Hi Yaw, thanks for the reply. > > I am using version collect 1.2.2 (1023) on a Motorola Atrix. > > I removed text from the public_key and submission_url fields in the xls > file, and verified that the xml form I have on the phone is recent (by > adding a note). > > When I try sending the form, the "Server Requires Authenitcation" popup > shows the URL as > > http://n.n.n.n/submission?deviceID=imeai%3.... > > and I used the default passwords in the collect settings as I did for the > Configure Site Access in the web page for the VM. > > I'm still getting 404--it seems to me the web server is having problems > with the "/submission?..." part of the URL. > > On Saturday, February 9, 2013 8:55:31 AM UTC-8, Yaw Anokwa wrote: >> >> Phil, >> >> What version of ODK Collect are you using? Try removing the >> submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in >> ODK Collect's settings as the URL, and put the username and password >> there as well. Does that work better? >> >> Yaw >> -- >> Need more help? Go to http://nafundi.com for custom development, >> professional support, form design, implementation advice, and user >> training for ODK. >> >> On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz wrote: >> > Oops, following the example, I now used for the submission_url >> > >> > http://nnn.nnn.nnn.nnn/submission/ >> > >> > and get the error >> > >> > Error: Not Found (404) at >> http://nnn.nnn.nnn.nnn/submission?deviceID=imei% >> > (a string of numbers presumably identifying the phone) >> > >> > So I think I'm closer but still no go. >> > >> > I should also mention that I have checked all boxes for the username in >> the >> > Site Admin tab of the VM's web page. >> > >> > >> > On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote: >> >> >> >> Hi all, I have downloaded the ODK aggregate VM and it seems to be >> working >> >> fine, I can get to it from the desktop as well as a phone using a >> browser. I >> >> have used XLSform to create a form and loaded that onto the phone, and >> the >> >> survey seems to run fine. In the "settings" tab of the xls file used >> to >> >> generate the form I have entered the form_title and form_id, deleted >> the >> >> public_key in the sample xls file, and entered the URL of the VM as >> >> >> >> http://nnn.nnn.nnn.nnn/ >> >> >> >> When I try to "send selected" I get the error >> >> >> >> Error: Invalid status code on Head request. If you have a web proxy, >> you >> >> may need to login to your network. >> >> >> >> Any ideas what I'm doing wrong? >> >> >> >> Thanks, >> > >> > -- >> > You received this message because you are subscribed to the Google >> Groups >> > "ODK Developers" group. >> > To unsubscribe from this group and stop receiving emails from it, send >> an >> > email to opendatakit-developers+unsubscribe@googlegroups.com. >> > For more options, visit https://groups.google.com/groups/opt_out. >> > >> > >> >

Phil,

Sounds like a permissions issue. Try using no username/password in
Collect and configure Aggregate so your anonymous user has all
permissions.

Yaw

··· -- Need more help? Go to http://nafundi.com for custom development, professional support, form design, implementation advice, and user training for ODK.

On Mon, Feb 11, 2013 at 11:51 AM, Phil Hurvitz phurvitz@gmail.com wrote:

Or maybe it is because I have these in my "survey" tab?

start
end
today
deviceid
subscriberid

On Monday, February 11, 2013 11:32:08 AM UTC-8, Phil Hurvitz wrote:

Hi Yaw, thanks for the reply.

I am using version collect 1.2.2 (1023) on a Motorola Atrix.

I removed text from the public_key and submission_url fields in the xls file, and verified that the xml form I have on the phone is recent (by adding a note).

When I try sending the form, the "Server Requires Authenitcation" popup shows the URL as

http://n.n.n.n/submission?deviceID=imeai%3....

and I used the default passwords in the collect settings as I did for the Configure Site Access in the web page for the VM.

I'm still getting 404--it seems to me the web server is having problems with the "/submission?..." part of the URL.

On Saturday, February 9, 2013 8:55:31 AM UTC-8, Yaw Anokwa wrote:

Phil,

What version of ODK Collect are you using? Try removing the
submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in
ODK Collect's settings as the URL, and put the username and password
there as well. Does that work better?

Yaw

Need more help? Go to http://nafundi.com for custom development,
professional support, form design, implementation advice, and user
training for ODK.

On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz phur...@gmail.com wrote:

Oops, following the example, I now used for the submission_url

http://nnn.nnn.nnn.nnn/submission/

and get the error

Error: Not Found (404) at http://nnn.nnn.nnn.nnn/submission?deviceID=imei%
(a string of numbers presumably identifying the phone)

So I think I'm closer but still no go.

I should also mention that I have checked all boxes for the username in the
Site Admin tab of the VM's web page.

On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote:

Hi all, I have downloaded the ODK aggregate VM and it seems to be working
fine, I can get to it from the desktop as well as a phone using a browser. I
have used XLSform to create a form and loaded that onto the phone, and the
survey seems to run fine. In the "settings" tab of the xls file used to
generate the form I have entered the form_title and form_id, deleted the
public_key in the sample xls file, and entered the URL of the VM as

http://nnn.nnn.nnn.nnn/

When I try to "send selected" I get the error

Error: Invalid status code on Head request. If you have a web proxy, you
may need to login to your network.

Any ideas what I'm doing wrong?

Thanks,

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I've tried altering permissions, usernames, etc. but I still get 404. It
seems to me that the server is attempting to load

".../submission?deviceID=imei%..."

and it kicks a 404 because it doesn't know how what to do with the URL as
it is formatted.

··· On Monday, February 11, 2013 1:26:40 PM UTC-8, Yaw Anokwa wrote: > > Phil, > > Sounds like a permissions issue. Try using no username/password in > Collect and configure Aggregate so your anonymous user has all > permissions. > > Yaw > -- > Need more help? Go to http://nafundi.com for custom development, > professional support, form design, implementation advice, and user > training for ODK. > > > > > On Mon, Feb 11, 2013 at 11:51 AM, Phil Hurvitz <phur...@gmail.com> wrote: > > > > Or maybe it is because I have these in my "survey" tab? > > > > start > > end > > today > > deviceid > > subscriberid > > > > > > On Monday, February 11, 2013 11:32:08 AM UTC-8, Phil Hurvitz wrote: > >> > >> Hi Yaw, thanks for the reply. > >> > >> I am using version collect 1.2.2 (1023) on a Motorola Atrix. > >> > >> I removed text from the public_key and submission_url fields in the xls > file, and verified that the xml form I have on the phone is recent (by > adding a note). > >> > >> When I try sending the form, the "Server Requires Authenitcation" popup > shows the URL as > >> > >> http://n.n.n.n/submission?deviceID=imeai%3.... > >> > >> and I used the default passwords in the collect settings as I did for > the Configure Site Access in the web page for the VM. > >> > >> I'm still getting 404--it seems to me the web server is having problems > with the "/submission?..." part of the URL. > >> > >> On Saturday, February 9, 2013 8:55:31 AM UTC-8, Yaw Anokwa wrote: > >>> > >>> Phil, > >>> > >>> What version of ODK Collect are you using? Try removing the > >>> submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in > >>> ODK Collect's settings as the URL, and put the username and password > >>> there as well. Does that work better? > >>> > >>> Yaw > >>> -- > >>> Need more help? Go to http://nafundi.com for custom development, > >>> professional support, form design, implementation advice, and user > >>> training for ODK. > >>> > >>> On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz wrote: > >>> > Oops, following the example, I now used for the submission_url > >>> > > >>> > http://nnn.nnn.nnn.nnn/submission/ > >>> > > >>> > and get the error > >>> > > >>> > Error: Not Found (404) at > http://nnn.nnn.nnn.nnn/submission?deviceID=imei% > >>> > (a string of numbers presumably identifying the phone) > >>> > > >>> > So I think I'm closer but still no go. > >>> > > >>> > I should also mention that I have checked all boxes for the username > in the > >>> > Site Admin tab of the VM's web page. > >>> > > >>> > > >>> > On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote: > >>> >> > >>> >> Hi all, I have downloaded the ODK aggregate VM and it seems to be > working > >>> >> fine, I can get to it from the desktop as well as a phone using a > browser. I > >>> >> have used XLSform to create a form and loaded that onto the phone, > and the > >>> >> survey seems to run fine. In the "settings" tab of the xls file > used to > >>> >> generate the form I have entered the form_title and form_id, > deleted the > >>> >> public_key in the sample xls file, and entered the URL of the VM as > >>> >> > >>> >> http://nnn.nnn.nnn.nnn/ > >>> >> > >>> >> When I try to "send selected" I get the error > >>> >> > >>> >> Error: Invalid status code on Head request. If you have a web > proxy, you > >>> >> may need to login to your network. > >>> >> > >>> >> Any ideas what I'm doing wrong? > >>> >> > >>> >> Thanks, > >>> > > >>> > -- > >>> > You received this message because you are subscribed to the Google > Groups > >>> > "ODK Developers" group. > >>> > To unsubscribe from this group and stop receiving emails from it, > send an > >>> > email to opendatakit-developers+unsubscribe@googlegroups.com. > > >>> > For more options, visit https://groups.google.com/groups/opt_out. > >>> > > >>> > > > > > -- > > You received this message because you are subscribed to the Google > Groups "ODK Developers" group. > > To unsubscribe from this group and stop receiving emails from it, send > an email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/groups/opt_out. > > > > >

What if you use a browser and enter that same URL into the browser?

What do you see? (it should prompt you for a login if you don't enable
anonymous submissions).

After logging in, it should present you with a submissions upload webpage
(because you're issuing a GET instead of a POST).

Mitch

··· On Wed, Feb 13, 2013 at 10:49 AM, Phil Hurvitz wrote:

I've tried altering permissions, usernames, etc. but I still get 404. It
seems to me that the server is attempting to load

".../submission?deviceID=imei%..."

and it kicks a 404 because it doesn't know how what to do with the URL as
it is formatted.

On Monday, February 11, 2013 1:26:40 PM UTC-8, Yaw Anokwa wrote:

Phil,

Sounds like a permissions issue. Try using no username/password in
Collect and configure Aggregate so your anonymous user has all
permissions.

Yaw

Need more help? Go to http://nafundi.com for custom development,
professional support, form design, implementation advice, and user
training for ODK.

On Mon, Feb 11, 2013 at 11:51 AM, Phil Hurvitz phur...@gmail.com wrote:

Or maybe it is because I have these in my "survey" tab?

start
end
today
deviceid
subscriberid

On Monday, February 11, 2013 11:32:08 AM UTC-8, Phil Hurvitz wrote:

Hi Yaw, thanks for the reply.

I am using version collect 1.2.2 (1023) on a Motorola Atrix.

I removed text from the public_key and submission_url fields in the
xls file, and verified that the xml form I have on the phone is recent (by
adding a note).

When I try sending the form, the "Server Requires Authenitcation"
popup shows the URL as

http://n.n.n.n/submission?**deviceID=imeai%3....

and I used the default passwords in the collect settings as I did for
the Configure Site Access in the web page for the VM.

I'm still getting 404--it seems to me the web server is having
problems with the "/submission?..." part of the URL.

On Saturday, February 9, 2013 8:55:31 AM UTC-8, Yaw Anokwa wrote:

Phil,

What version of ODK Collect are you using? Try removing the
submission_url from the form. Instead, put http://nnn.nnn.nnn.nnn in
ODK Collect's settings as the URL, and put the username and password
there as well. Does that work better?

Yaw

Need more help? Go to http://nafundi.com for custom development,
professional support, form design, implementation advice, and user
training for ODK.

On Fri, Feb 8, 2013 at 6:51 PM, Phil Hurvitz phur...@gmail.com wrote:

Oops, following the example, I now used for the submission_url

http://nnn.nnn.nnn.nnn/**submission/http://nnn.nnn.nnn.nnn/submission/

and get the error

Error: Not Found (404) at http://nnn.nnn.nnn.nnn/**
submission?deviceID=imei%

(a string of numbers presumably identifying the phone)

So I think I'm closer but still no go.

I should also mention that I have checked all boxes for the
username in the

Site Admin tab of the VM's web page.

On Friday, February 8, 2013 6:37:22 PM UTC-8, Phil Hurvitz wrote:

Hi all, I have downloaded the ODK aggregate VM and it seems to be
working

fine, I can get to it from the desktop as well as a phone using a
browser. I

have used XLSform to create a form and loaded that onto the phone,
and the

survey seems to run fine. In the "settings" tab of the xls file
used to

generate the form I have entered the form_title and form_id,
deleted the

public_key in the sample xls file, and entered the URL of the VM
as

http://nnn.nnn.nnn.nnn/

When I try to "send selected" I get the error

Error: Invalid status code on Head request. If you have a web
proxy, you

may need to login to your network.

Any ideas what I'm doing wrong?

Thanks,

--
You received this message because you are subscribed to the Google
Groups

"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an

email to opendatakit-developers+**unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+**unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com