Upload results - Exception getting or creating root folder for submissions

1. What is the problem? Be very detailed.
I have recently been getting a new error wherein all ODK Collect forms that would previously upload (to Google Sheets) without a problem are now all throwing an error "Exception getting or creating root folder for submissions" . I can't think of anything I have changed recently except updating ODK Collect.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Collect: v 1.21.1
Android: 8.1.0
Phone: Vivo V9 Youth

3. What you have you tried to fix the problem?
tried checking if other devices are having the same issue and they are not.
two individuals were able to submit responses to google sheets for the same forms that I am having issues with.

4. What steps can we take to reproduce the problem?
one of the forms I am having trouble with is attached , name 'hhSurveyFD20190501.xml'
hhSurveyFD20190501.xml (52.1 KB)

you could try uploading sample responses to this. I have set the google sheet to accept edits from anyone who has the link.

Screenshots of the error also attached
the first error is what I see when auto upload is turned on

the second error when I manually select a form for upload

any chance of a resolution here?
This error is incredibly hard to figure out.
Tried uninstalling the app, deleting all ODK folders and then reinstalling and still no change.

Getting the same error with multiple sample ODK forms too
Any help would be great!


Hi @craigdsouza

I'll look into the issue today or tomorrow.


It happens if you have two (or more) folders named Submissions in your Google Drive -> Open Data Kit. the folder should be unique. Could you confirm it was the cause?


Yes! @Grzesiek2010 thank you! that resolved the issue.
I'll clarify further.. I had one Open Data Kit folder with 'Submissions' within it that I owned.
There was a second folder that someone else owned, but I had edit access to, similar structure i.e. Open Data Kit > Submissions
So I deleted my own 'Open Data Kit' folder and then tried sending and it worked, however it sent the image with the form to the folder that I do not own. So I now have to either give up edit access to the second folder , to successfully submit to my own drive folder