"Upload Results: Sorry, no form was uploaded."

What is the problem? Please be detailed.

Hello—I followed this youtube tutorial to get set up with ODK collect and google sheets. In the past this method has worked swimmingly for me. But now when I go to send a finalized form, I get the error message in the topic title: "Upload Results: Sorry, no form was uploaded."

What ODK tool and version are you using? And on what device and operating system version?

Collect v1.19.0
Pixel 2XL
Android PQ1A.181205.002

What steps can we take to reproduce the problem?

-Create a new xml form via google sheets + XLSForm-Online
-Same thing happens with a form authored on ODK Build
-Set submission_url (either settings tab of custom spreadsheet or edit -> form properties in ODK Build) to the r/w permission url for a google sheet e.g.:


What you have you tried to fix the problem?

Tried a number of variations on the submission_url value, but the documentation is kinda lacking on this. The best and really only example I could find for google sheets workflow was in the above mentioned/linked youtube video.

Server settings are set to google drive / google sheets.
I am signed in to my google account in collect, no auth issues to speak of.
I am sending via wifi/cell.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi @cinemarob1

I've been playing with this feature recently a bit and I didn't notice anything strange. I was even able to send my form to your sheet.
My first question would be:
Are you able to open your GD from Collect when your settings are set to google drive/google sheets? (Get Blank Form button from the main menu)?

Thank you Grzegorz,

I can download the blank XML and fill it out, but to answer your question, no, I cannot see or open the original google sheet from Collect.

but can you see the content of your GD (folders, files whatever you store there) after clicking the Get Blank Form button? Or maybe there is an error?

I can access my files in GD from Get Blank Form, yes. The error does not occur until after I get the form in collect, fill it out, and attempt to submit finalized. Here is the form I am trying to use, maybe I am just fundamentally misunderstanding how to format a form:


Hmmm I just downloaded your form and sent data to your sheet with ease. Could you try again?

1 Like