Uploading odk collect form to aggregate

Hi All,

I am trying to upload a completed form to aggregate but getting the following error:-

Error: Generic Exception: stream was reset: NO_ERROR

Sending failed on Wed, Aug 05, 2020 at 08:40

Aside from changing and testing other url's is this a common occurrence...a firewall blocking? Do you need more information?


Your post does not contain enough information for us to answer your question. In general, the best way to get help is to fill out the questions in the pre-filled template that you get when you create a support post. So, with that in mind, can you answer these questions?

  1. What specific versions of Aggregate and Collect version are you using?
  2. In the case of Aggregate, where did you install it (e.g., Digital Ocean)?
  3. Has this server ever worked before? If so, what has changed?
  4. Has the app worked before with other servers (e.g., opendatakit.appspot.com) on this connection?
  5. Is the submission you are sending big (e.g., pictures/video) or small?
  6. Do your server logs give any hints to the problem?

Do you managed to solve this problem ?, I would also like to upload the form already filled in, do you have any idea how to do this?

Hi BrunoAngelo,

No...I switched to GoogleSheets which works well. Will eventually move to 'central' at some point.


got it..thanks for replying