UTF-8 Characters in .csv media files on a form

Hello everyone.

I am having some issues with displaying characters on the ODK Collect application. I have the "choices" lists separated in external files (for example "clients.csv"). These choices often include special characters, such as "č,ć,š,đ,ž", which are not displayed properly on the mobile app. They appear as question marks.

Example of a line in the external choices file:
ž and Ž get displayed as question marks on the ODK Collect application.

The .csv file is properly saved, as when I download the currently used .csv file (from the ODK Central, as shown on the picture below), the special characters are present, so it's not an issue with the file format.

I am wondering if there is a way to fix this, as these characters are part of official names of the products/clients/employees and it would be improper to use 'c' instead of 'č' for example. I'm assuming it has something to do with how the ODK Collect application is displaying characters, but any help would be appreciated.


What version of Collect are you using? And on what device?

I am using the latest version of ODK Collect on an Android system (Samsung Galaxy A50).

We have tests to confirm Unicode characters in data files work in Collect, so something strange is happening.

I'm assuming the CSV has information that you can't share publicly? Please send me a personal/direct message with the CSV you download from Central. Don't open the file, just download it, and attach it to a message.

It was an issue on my part. The file doesn't want to save as UTF-8 for some reason. I tried following the steps on this page without any success: https://answers.microsoft.com/en-us/msoffice/forum/all/how-to-enable-save-as-csv-utf-8-encoding-in-excel/cf7c54f7-a067-4337-9ed9-00b93a591831

I found somewhat of a workaround (under Manually set and save file encoding via Notepad section): https://help.salesforce.com/s/articleView?id=000324657&type=1, but this is a bit inconvenient, as I have to keep two versions of the file, and if I open the file in Excel it gets converted back to ANSI, and it's not very readable because the special characters get transformed.

Regardless, I'm sorry for any confusion I may have caused.

Thank you for your help,

If the latest versions of Excel don't work, try Google Sheets or LibreOffice and see if those work better as far as UTF-8 support.