VM cannot be imported into VMWare environment

Thanks to you good folks for putting this together - I hope others are using it.
I finally downloaded the .ova.zip file and tried importing it in to my enterprise VMWare environment... it failed with this error: (screenshot attached)

I poked around and found a "converter" for OVF to VMX - this might help someone else:


install the vmware package,

then you have to extract the OVF file
then copy the file to the same directory as the ovftool

and then run it at the cmd line like this:

cd "C:\Program Files\VMware\VMware OVF Tool"


PS C:\Program Files\VMware\VMware OVF Tool> .\ovftool.exe .\ODK-Aggregate-v1.5.0-beta.0.ova
OVF version: 1.0
VirtualApp: false
Name: aggregate

Download Size: 0 bytes

Deployment Sizes:
Flat disks: 0 bytes
Sparse disks: Unknown

Name: NAT
Description: Logical network used by this appliance.

Virtual Machines:
Name: aggregate
Operating System: otherguest
Virtual Hardware:
Families: virtualbox-2.2
Number of CPUs: 1
Cores per socket: 1
Memory: 1024.00 MB

  Index:          0
  Instance ID:    7
  Capacity:       64.00 GB

  Adapter Type:   E1000
  Connection:     NAT

Converting it didnt work either:

PS C:\Program Files\VMware\VMware OVF Tool>
PS C:\Program Files\VMware\VMware OVF Tool>
PS C:\Program Files\VMware\VMware OVF Tool>
PS C:\Program Files\VMware\VMware OVF Tool> .\ovftool.exe .\ODK-Aggregate-v1.5.0-beta.0.ova ODK.vmx
Opening OVA source: .\ODK-Aggregate-v1.5.0-beta.0.ova
Opening VMX target: ODK.vmx

  • The specified operating system identifier 'Debian_64' (id: 96) is not supported on the selected host. It will be mapp
    ed to the following OS identifier: 'Other (32-bit)'.
    Error: OVF Package is not supported by target:
  • Line 25: Unsupported hardware family 'virtualbox-2.2'.
    Completed with errors
    PS C:\Program Files\VMware\VMware OVF Tool>

My understanding is that there is a 8 year old bug in VirtualBox that causes it to generate VMs that are incompatible with VMWare's ovftool.

ODK could build a VMWare-specific VM, but that requires a VMWare license and I don't like adding proprietary dependencies to the project if there isn't strong demand.

I think you can instead edit the ovf and replace virtualbox-2.2 with vmx-07 and that should work. I say should because I haven't tried it myself. There are instructions below that should help:

We also have Docker support that's documented at https://github.com/opendatakit/aggregate/tree/master/docs that might be a good option.

1 Like