XLSForm Offline 1.4.0 ODK Validation errors

What is the problem? Please be detailed.
When I try to convert forms from XLXS to XLM format I get this error:

ODK Validate errors:
Exception in thread "main" java.lang.NoClassDefFoundError: org${XFormParseException}Caused by: java.lang.ClassNotFoundException: org.javarosa.xform.parse.XFormParseException ... 3 more

What ODK tool and version are you using? And on what device and operating system version?
XLXForm Offline 1.4.0

What steps can we take to reproduce the problem?
Test any form with XLSForm 1.4.0

What you have you tried to fix the problem?
I have created some new versions of my forms. I have uploaded previous versions that have been converted before and that I have not edited further and I now get this same error.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
I can provide upon request.

1 Like

A quick update, I was able to use the online XLSForm to convert XLSX files to XML using Chrome on my Mac without error.

1 Like

Are you using the OS X version of XLSForm Offline? Have you tried ODK XLSForm Offline v1.5? With that version I'm not able to reproduce the issue you've run into.


Thanks! Using version 1.5 does not produce that error with the same files.


Should there be a way to directly update XLS Form Offline or a check for update? I just had same issue also fixed by updating but I was not aware that XLS Form Offline had been updated

That would be a nice feature for sure! I've filed it at https://github.com/opendatakit/xlsform-offline/issues/13. This would be a nice contribution for someone who knows a little bit of Python.

Until that feature ships, you can always watch the releases category and you'll be notified automagically when there is a release for any ODK tool.

Both XLSForm Offline 1.4.0 and XLSForm Offline 2.0.0 can't run in my Windows 10, the error message says "This app can't run in your PC" (or something like that). I've tried "troubleshoot compatibility" and some other ways on the internet (to run older apps in windows 10), but those ways are not work.

I don't know why the XLSForm Offline 1.5.0 works on Windows 10 :smiley:

Thanks alot, glad to find your reply.