XLSForm online and Firefox - can't download xml

What is the problem? Please be detailed.
Recently I have not been able to use xlsform online (since mid December) - I can upload a form but the frame does not reload to allow me to download (or give me the error message if the xlsx file has problems). Is this a problem with my settings for Firefox, or has something changed on your server?

What ODK tool and version are you using? And on what device and operating system version?
Windows 10, Firefox 57.0.4

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?
Used Microsoft Edge and Explorer. This sort of works, but downloading the xml is problematic (I don't know how to save the xml from these browsers and end up cutting and pasting the link into firefox!)

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
I'm not usually as stupid as it looks like by this problem :slight_smile: I suspect it's something really obvious that I am already staring at?

Hi @seewhy, thanks for the detailed report!

We did change to different infrastructure on the server in November (See ODK XLSForm Online v1.0), so that probably explains the change.

But, I've been able to try a basic form on Firefox 57 on macOS and Windows 10 and it works great for me.

Do you see the same screen that I'm seeing above? Can you try the basic form to see if that works?

Hi @yanokwa,
Thanks for getting back to me quickly. Unfortunately I can't get this to work on my system - your screen shot shows what I used to see!
What happens is that the grey area goes blank once I hit 'submit':

When I try to upload it using Edge there is a message saying that the content can't be displayed in a frame:

But if I copy the link location and open with Firefox, it downloads the xml file!

So not sure if that is a problem at my end (e.g. settings on my browsers), or with your system? Odd that it happens with both browsers, but maybe that just means I'm special :slight_smile:
Kind regards

It looks like somehow Firefox and Edge aren't allowing iFrames to load. What happens if you go to and load a form. Does that work?

Ah, I'm working you hard today! Thanks for this. Yes, using this route works perfectly, so the iFrame isn't loading correctly.

Except that I've just tried it again at the normal address and used the 'inspect element' tool in Firefox to check if the iFrame was loading and as if by magic (or your hard work) it now works!

Still the same result in Edge.

I have a workaround now though even if Firefox gets wobbly again - thanks.

Appreciate your help. Again.

Glad I could help and hopefully you can help someone else on the forum!

When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!