0 submission odk briefcase

Hi everyone,

I'm new with ODK (just for you to now I just use it offline, no aggregate server, etc...) and cannot find the information I'm looking for, in the forum this time although usually I found it. I believe there is an information I'm missing when I'm trying to export data.

1. What is the problem? Be very detailed.
I used ODK breifcase 1.3 to export csv from a form. It used to work perfectly when I was creating two folders : "forms" and "instances" in ODK briefcase storage. I downloaded the 1.17.3 version of odk briefcase to benefit from the new feature to split multiple choices.
With this version when I try to export my data, I got 0 submission, as if ODK briefcase coudn't find my instances and process them. I think there is something I'm missing but even when I looked at https://docs.getodk.org/briefcase-using/#export-forms-to-csv I couldn't find it.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK briefcase 1.17.3

3. What you have you tried to fix the problem?
Look at the forum
Put forms and instances directly in ODK briefcase storage (removing folders "forms" and "instances").

4. What steps can we take to reproduce the problem?
No idea

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
just for you to see how I arrange the ODK briefcase storage I think the issue comes from here.
Waiting for your support, feel free to ask other questions

Hi, this is for sure a difficult case to troubleshoot remotely. Does briefcase record any errors or message which may give clues? Do each of the folders in your "instances" screenshot contain an xml file and does the "forms" folder have any files in it?

Hi Noel,

Thanks for your return. It seems there is no error with briefcase (see screenshot attached). Every folder in instances contain an xml file and the "forms" folder contains the xml of the form.
I don't understand it used to work with 1.3 version. I think briefcase doesn't find the instances when exporting. Do you have any idea if the issue comes from the 1.17 version?


You could try removing the file called cache to another location (odk briefcase will replace it with a new copy anyway as its a temporary file). It would also be worth removing any existing csv file with the name of that form from the folder you are exporting to. I cannot be sure but it may be that changing versions of ODK briefcase has caused the tool to lose track of which instances it has already exported and which it hasnt. I dont know exactly why that happens with briefcase but its something which has worked for me in the past. If you want to be sure to take no risks in the trial, rather than delete the above files entirely you can just move them temporarily to another folder.

Thanks again, I tried your proposition but still I couldn't get a submission.
Is anyone in the same situation ?



Some progress has been made today. I've used briefcase 1.17 version with an old form which worked in the past.The submission process worked perfectly then I tried again with the form with submission issues and still I got no submission. I've looked in the folders forms and there are differences between both. I don't know if it explains the 0 submission issue and hope you can help me.

Below in the screenshot, folder n°1's submission worked but folder n°2 didn't...
Do you have any idea ?

Thanks in advance,

2 posts were split to a new topic: Briefcase not exporting encrypted submissions pulled from Kobo