500 when trying to log in after Central v1.2 upgrade

Need your help. I have upgraded ODK Central to v1.2. Tried "docker-compose ps" everything is perfect but while trying to log in, it says "Something went wrong: error code 500."

Tried re-building. However, I have an external volume for my storage on the digital ocean connected with this instance.

Upgrade/ Pull is successful but unable to log in. Please refer screenshot and suggest.

Can you try a hard refresh in the browser?

Tried the same. In addition, tried using other browsers too. Further, the APIs works fine. The issue seems to be with the front end.

Do you have access to the logs for what you've deployed? Docker's logs should give you a more informative error.

I was able to resolve the issue by increasing the RAM of the server. The error was due to out of memory.

Thanks all for your help and prompt support.

2 Likes

A post was split to a new topic: Connection timeout after upgrading to Central v1.2

I'm glad you got it fixed and thanks for sharing your experience, @rameshbhalla81.

It would be very helpful to hear how much RAM you had before the upgrade and how much you've now increased it to. Had you configured swap?

@LN I do have configured the swap. I have just upgraded it to 4 GB RAM with 160 GB of additional volume storage.
Thanks for your response and appreciation.

1 Like