After publishing draft, unable to send finalized forms collected with draft version

**1. What is the problem?
I tested the draft version of my form on my mobile device afyer which i published the form. While my other app users had the published formand could send their forms after data collection, i could npt and only realised mine was still the draft form.
I am getting "Eror:generic exception. Could not find the resource you are looking for ".

Any help on how to get the data?

2. What app or server are you using and on what device and operating system? Include version numbers.
ODKCollect, Samsung galaxy A02

3. What you have you tried to fix the problem?
I have tried

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Welcome to the ODK community forum @sannirukayat ,

when you'll get a chance please introduce yourself here :wink:

Maybe I am wrong but I think you are still using the test form on you Collect app. As you publish your form, the test instance does not exist anymore and you need to connect to the project hosting the form and fill the form from here.

Thank you for your response.

Yes i realised same. I thought i read the form will be updated once published but i was wrong.

Does it mean there is no way to access the data again?

If you used a draft of the version that you ended up publishing, you can go to settings (from the landing screen, tap on the project icon at the top right, then Settings) and then at the bottom tap on Project management, Reconfigure with QR code, and scan an App User code that has access to your published form. That should allow you to send those submissions. If not, please share what error message you're getting.

1 Like