Aggregate refreshes indefinitely

Hi, I encountered a problem with my previous ODK deployment. Here are the installers that I used:

Server OS: Windows server 2012 R2
Apache Tomcat 6.0.37
ODK Aggregate v1.4.11
PostgreSQL 9

After just a few days, the ODK Aggregate website is loading repetitively that i cannot even hit the login button. The downloading and sending of data to the server is also affected and gives a Generic Exception Error:(500).

I tried to resolve it but to no avail, so I decided to install the new version of ODK Aggregate and the following installers:

Apache Tomcat 8
PostgreSQL 10.7
Aggregate v20

I still got the same error. I attached the video of the the website's behavior.

Thank you and hoping to get help from you guys.

Welcome to the ODK forum, @melbreganza ! We're glad you're here. When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

This is a known error when the database gets corrupted, often due to partial submission uploads under poor networking scenarios. Unfortunately, you won't work around this issue just by updating Aggregate. This post explains what you can do to fix this: ODK Aggregate Keeps Refreshing

1 Like

Hi @ggalmazor thanks for a warm welcome.

Thank you for responding to my queries. This is a great help. I thought all along that maybe compatibility with the server and other components is causing the problem. Thanks also for providing the link to ways to troubleshoot this problem. I will try it and will update you with the result.

Again, thank you very much!

2 Likes

Thank, you for participating in the community! Welcome again!

1 Like