Briefcase 1.17.0 slow to open

1. What is the problem? Be very detailed. ODK Briefcase v1.17.0 is very slow to open: 65 sec on a Windows 10 computer (vs 6 sec for v1.4.4 Production), 115 sec on a Windows 7 computer (vs 15 sec for v1.4.4 Production). I would like to use new features in v1.17.0, but it takes an unreasonable amount of time to open.

2. What app or server are you using and on what device and operating system? Include version numbers.
Win 10 computer: Lenovo Flex3-1580, Intel I-7 2.50GHz, 8GB RAM, 64 bit Windows 10home, latest updates installed, 1TB SSD 438GB free
Win 7 Computer: Acer Aspire E1532, Intel Celeron 1.40 GHz, 4GB RAM, 64 bit Windows 7 Home Service Pack 1, latest updates installed, 450GB HDD 375GB free.
Both computers: Java Version 8 Update 221 64bit, Java 7 uninstalled. Path updated with new installation, references to previous version deleted.

3. What you have you tried to fix the problem? Check and recheck updates; tried opening from desktop shortcut and directly from .jar file, also from command line, with similar results

4. What steps can we take to reproduce the problem? Check time required to open Briefcase v1.17.0 on another computer.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below. Briefcase v1.4.4 seems to work fine with the updated Java, so I will continue with that version for now, and do without the highly desirable enhancements of v1.17.0. Can the new version be made to work more efficiently?

Thanks for reporting this issue, @Hayden_Boyd!

Could you give an estimate of the number of forms and submissions you're dealing with? Also, could you describe the forms so that we can get a rough idea of their size in fields, or maybe if they have binary attachments for pictures, or sound/video recordings?

Also, are this opening times recurrent everytime Byou try to open Briefcase, or just the first time you open Briefcase v1.17?

Thanks for your speedy reply, @ggalmazor! The slow opening issue occurs independent of any forms or submissions. In other words, it's slow to open when you just click on the .jar file. The few times I've tested pull and export with small test forms, it appears to work normally once it opens. It is slow to open each time - I have tested and timed the opening many times on both computers, always with similar results. Using the command line, with v1.17.0, there is a very long wait before the write to ODK Briefcase Storage starts, much longer than using v1.4.4. After the process starts, the write to Storage and the subsequent export to csv & media seem to proceed at the same 1.4.4 pace I'm used to, even with quite large forms that include a photo. I hope this information helps. HB

1 Like

Thank you so much, @Hayden_Boyd!

Now I think I need to know a little more about the computers you're using for testing this. Could you describe both environments, please? I'm sorry to have to ask annoying obvious questions but, both computers have similar hard-disk drives? Are there any network-mounted directories in any of them, etc? What Java versions are you running on each?

Another thing that could help me locate the cause for this slowness would be to have an exact copy of a storage directory that you've found to be slow. One with a test form would suffice and you can ZIP it and attach it here if you want. You can send it to me to my personal email address at as well.

Aside from the info in #2 of my original post, I would add that neither computer has a network-mounted directory. Everything is slower on the older Win 7 computer, as expected, but v1.17.0 opens too slowly even on the more powerful Win 10 computer.

The problem with v1.17.0 occurred with a new installation in each case. When I click on the .jar file, Briefcase opens after a long delay, I specify the location in Settings and it creates an empty storage directory. Subsequent attempts to open the app use that same (empty) storage directory, and every attempt experiences the same long delay. I do not believe the problem has anything to do with my forms or instances, since the slow-opening problem occurs even before I start using it with forms and data.

1 Like

Sorry, I forgot about #2!

It should be much faster on Win10 with an SSD, that's for sure.

Do you see any difference between double clicking the jar file and launching it using PowerShell/command line?

I'm sorry to ask about the environment again, but your environment is pretty much the same we use for Q&A before each release and our test team didn't report slowness, thus, making your environment the most probable cause for it. I want to be sure about this before doing more complicated tests.

Hi @Hayden_Boyd,

Can you locate the briefcase log file? Sharing it with @ggalmazor may provide better insights.

Hi @dicksonsamwel - Can you please advise me how to locate the Briefcase log file. Or, if action is needed to enable generating such a file, how can I do that?

Hi @ggalmazor,

Just wanted to share my experience on this, I started using v1.17.0 when it was out and the delay I experience before it launches is about 6 seconds. I currently have one form with about 1000 submissions.

Am using Thinkpad X1 with win 10, Processor, Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2712 Mhz, 2 Core(s), 4 Logical Processor(s).

1 Like

You can locate the briefcase log file in the same location with the jar file.

You should see a text file with the name "briefcase.log"

@mmarciniak90 and @kkrawczyk123 Is this a regression you can reproduce?

hi @ggalmazor,

Per @dicksonsamwel suggestion, I've attached the log file for a command line Pull/Export of three test forms. (I found the log file in my \Documents folder, after searching the C drive). The Aggregate instance is on a local Tomcat server. The computer is the Win 10 computer referenced in my original post.

I started the script precisely 10:45am by the computer's clock. The log shows a 50 second delay before things start, which is consistent with the time to open Briefcase by clicking on the .jar file.

I also opened Briefcase and did a manual export of the same forms, but it did not add to the log or generate a new log.

briefcaselog.txt (4.8 KB)

You suggest a problem might be with the environment on the two computers, which makes sense given that others do not experience the long opening delay. Can you guide me as to what to look for? Thanks. HB

1 Like

Thanks, @Hayden_Boyd!

I don't see any clues in the log file.

We're running out of things we could try but there's something simple that you could do: switch computers to see if the slowness remains.

In any case, we're working hard to make Briefcase faster and the upcoming v2.0 version will have a new revamped workspace and form storage system. We don't expect to make any performance improvements to the v1.x branch.

It would be great to have your help testing the first v2.0 beta version. We're expecting to release it during November.

A post was split to a new topic: Update notice keeps checking for updates

Thanks @ggalmazor. I'd be glad to help with the v2.0 beta version in November. In the meantime, we are continuing with v1.4.4. Appreciate your help with the v1.17.0 mystery.


We are using windows VM for release testing. Everything is slow on VM so hard to feel any differences between latest versions.
I have done a little research on machine with Windows 8.1 16GB Ram Intel® Core(TM) i5-3210M CPU @ 2.50 GHz.
my results are:
v1.17: 12,5s; 5.5s; 7s
v1.16.2: 5s; 5s; 5s
v1.16: 3.5s; 4s; 4s
v1.15: 6s; 5s; 4.5s
v1.14: 4.5s; 4s; 5s

hope that any of them are helpful somehow. 12.5s is quite long and surprising.

1 Like

Thanks, @kkrawczyk123!

I see that the first number doubles from v1.16.2 to v1.17, which is not good. What do those numbers mean, anyway?

It is time of launching in seconds.

Then, they are times from three different launch attempts?