Error: list index out of range

1. What is the issue? Please be detailed.
When I try on it just throws this message

When I try to implement in kobo it throws this

no puede implementarse su formulario porque contiene errores:

ODK Validate Errors: >> Something broke the parser. See above for a hint. Error evaluating field 'sumapicos_c_sub_1' (${grupo_gnral}[1]/grupo_correcion[1]/repeat_correccion[1]/pulverizacion_c[1]/repeat_seccion_c[1]/sumapicos_c_sub_1[1]): The problem was located in Calculate expression for ${sumapicos_c_sub_1} XPath evaluation: type mismatch indexed-repeat(): parameter 2 must be a parent of the field in parameter 1 Caused by: org.javarosa.xpath.XPathTypeMismatchException: The problem was located in Calculate expression for ${sumapicos_c_sub_1} XPath evaluation: type mismatch indexed-repeat(): parameter 2 must be a parent of the field in parameter 1 ... 10 more The following files failed validation: ${tmpvyaifo89} Result: Invalid

2. What steps can we take to reproduce this issue?
Test on and on kobo tool boxs platform

3. What have you tried to fix the issue?
We are working on it Error with XLSForms for ODK with great help from @mathieubossaert mathieubossaert

4. Upload any test forms or screenshots below.

PRUEBA.xlsx (264.5 KB)

Hi @Varo

it was just an excel problem.
I opened it and save it and now it "works" but you still have the problem
PRUEBA.xlsx (674.0 KB)

Thank you so much @aurdipas !!! nice to hear you
We are not being able to solve it, can anyone think of what it could be?
Thank you very much in advance

Hi Aurelio,

could you tell us more about it ? What did you do ? I am really affraid I face a bug with LibreOffice xlsx format.
Saving your form form as a new xlsx one with LO reproduce the error :scream:

I think it is a bug as I tried to explain here :

Can you try the workaround to split long "if" statements into 2 smaller ones.

I just opened it with microsoft excel. Save it and then upload it to convert it and works.
Normally I face the opposite, a file get corrupted in Microsoft excel and when I open it with LO and save it that fix the issue.
I believe that the problem with Microsoft is that when people select all, copy and paste sort of "activate" all columns/rows in the file.
When I open that file with LO I get a message saying "max nb of columns exceeded" and that LO had to limit the nb.
I agree, save it and all is fixed.

But works on XLSForm Online v1.x...

With this particular file oepningin with LO and Saving as don't work, even with an intermediate format as ods or xls.
The only way I just found to get it work was to copy / paste the sheets content (not all the lines and columns) from your file to a new one, and then save as xlsx. The final weight 83 ko vs. 250 for the original.

Hope we will note face that problem to many time, I Will some difficulties to run excel on my Linux machine :slight_smile:

We had to change the library used to parse XLSX files recently and have had some new issues come up.

This seems like it is in the same class of problems as

Does this Stackoverflow post help?

Thank's @LN,

I learned this on a previous TAB "podcast".

Yes, I also face slow conversion, and once I got a "service unreachable" as Theron.
I got this "out of range index" error for the very first time yesterday with Varo's form. For the moment we do not face it with our own forms.

I tried the 2 xlsx saving option in Libre Office. They both don't solve the problem.

Thanks again.

If you still have the form that had this property, please share it. Details on what version of LibreOffice you used and anything else possibly interesting about your workflow or way you saved the file would be helpful (e.g. did it start out in Excel, etc).

This is the first time I see it too. Thanks for checking on the saving options.

1 Like

Hi @mathieubossaert @aurdipas @LN

Thank you very much for all the collaboration.
We saw that there are several technical messages in this topics.
Now we are testing the form well and the real use from the mobile and soon we will give you the feed back well.
Thank you very much

1 Like

hi @mathieubossaert @LN @aurdipas

First of all, again, thank you very much for the collaboration.
I give you the feed back of the tests we were doing.
Effectively now it correctly implements the form corrected by @mathieubossaert on the servers.
When we went to test the mobile application, we saw that in previous versions, the same error was displayed on mobile phones, but using the latest version of ODK Collect it already worked correctly.
As a conclusion, creating long calculates as suggested in these topics and using the latest versions of mobile are the solution.
Thank you very much for everyone in this collaboration