Infinite spinning while getting location with Bluetooth GPS device

What is the problem? Please be detailed.
We are running multiple forms on multiple Android devices including Samsung 5 Active, Google Nexus 5, Google Moto X4. We have been using a BT GPS connected through a BT GPS App rather than the phone GPS. Just recently, our forms started failing to acquire a location (GeoPoint). Has anyone else run into this problem. All phones and forms were working just prior to the failure. I am thinking that ODK must have updated and as it updated on each phone they started to detect the problem. We are now running V1.13.2. I also tested this on public forms to make sure we hadn't made a mistake somehow.

What ODK tool and version are you using? And on what device and operating system version?
v1.13.1 various android OS versions. Lollipop to Oreo.

What steps can we take to reproduce the problem?

Connect a BT GPS, set Mock Locations in Developer Options, grab a Geopoint in any form.

What you have you tried to fix the problem?

Uninstalled and reinstalled BT GPS App, ODK, Reset Factory settings on phone and started from scratch.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Thank you,

Can you please say more about exactly what is happening? Is it hanging indefinitely? Is the accuracy not what you would expect? Something else? Have you verified that other apps can get location as expected?

As far as I know, there has been no recent change to Collect that would affect this behavior. The location code was updated in July or so to use more modern tools. Have you been updating Collect consistently? What was the last version you know worked for sure?

Hi Hélène,

We either get a message that says "Using Fused" or it will spin indefinitely even though the BT GPS has 1 to 2m accuracy. Normally, this step takes about 1 sec to complete. When using fused we are getting initial accuracies of 10-13m. We want to use the BT GPS for better accuracy and longer battery life on the phone. The BT GPS has no problem connecting to the phone or being used by the BT GPS App, Google Maps, Back Country Navigator or Locus Maps. The accuracy reported by the BT GPS is 1.6m.

We never had the "using fused." message until this problem started.

Collect updates automatically, so I'm not exactly which version we were using prior to experiencing this but it appears to affect all our phones now.

What are your location settings at the Android level set to? Here's how to see them on some devices:; on my device it's Privacy > Location.

Your "Location method" should be set to GPS only. If it's not, what is it set to? If you change it to GPS only, do you see any change in behavior? What happens when you try to get a geopoint without the external GPS?

I unfortunately don't have a bluetooth GPS to verify functionality with. Does someone else in the community use such a device and are things working as expected for you?

Just as a quick initial response, we are using Garmin Glo devices as external GPS receivers and have been having similar issues. I can provide more info later.


If you are having GPS problems, please try the ODK Collect v1.14 Beta.