Input data get missing in the "Edit Saved Form"

What is the problem? Please be detailed.
I am currently carrying out yield survey on cashew plantation with two set of questions uploaded on 135 tablets. The producer's details like farmers's ID number, producer's name, etc are the same for the two questionnaires. Unfortunately for me and my enumerators, we are not able to finish one form(questionnaire) at ago. but when we save the form and want to continue where we left the last time, some data already entered like "name of the producer, age, region, district, village and other questions answered by the farmer disappeared in the form whiles in the edit saved form, therefore we have to start almost like filling the forms again. Such areas are also relevant and need to be filled.

What ODK tool and version are you using? And on what device and operating system version?
ODK tool- ODK build
ODK version - ODK collect v1.18.2
Device - Samsung Galaxy Tab A6
OS - Android version 5.1.1

What steps can we take to reproduce the problem?
such question were in groups. I have collapsed them in groups tried to put them under different questions but still not reproducing for the problem at hand

What you have you tried to fix the problem?
Not yet.
My enumerators have started collecting the data and i have to stop them because of this particular issue.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
Attached are screenshots for further understanding.

Hi @Frimpongeben1 it doesn't look like your screenshots came through. Can you try again to attach them? Thank you.

This is the screenshots of one typical example in the "Edit Saved Form in the ODK collect v1.18.2. The Q1.0 "would you like to participate in this survey" in English, the options were YES and NO. whiles some answers are appearing after saving, some questions seems to be not answered at all, eg is the Q1.0 which does not allow to save as finalized form.
I am not used to the xls format, I am currently using the build.
Please kindly advice on this issue.
Thank you.

Could your enumerators be using the question navigation option to skip the question without providing an answer?
08%20PM


ODK Build should have an options to Save Form to File... and Export to XLSForm
Either of these files will help troubleshoot if there is something within the form that may be causing a problem.

They can skip the question though, but because such question is relevant, it does not allow them to save form as finalized.
They could save and mark as finalized but because the data is not taken at a time, it is not possible to mark as finalized.

Hi Boss,
Have you ever come across a situation in the ODK collect on the tablet, where if an enumerator enters the data and save it to continuing taking the data later, then some responses already entered may be disappearing.
I am currently using the Build. My questionnaire is also designed in such a way that the enumerator cannot take the data the from the farmers at once. This spread over some period. But currently, I am experiencing that issue. Please kindly help me if you have come across such issue.
Than You.

Hi @Frimpongeben1,

There is no need of creating a separate thread.

No, I have never come across that. After data have entered how do you extract the data? Have you downloaded the excel with data? It is missing there as well?

@dicksonsamwel,
My usual downloading format is the XML data. I have not tried downloading it to excel data because I am not used to the ODK excel format. If so by downloading it to the excel data then how do I upload it onto the server.

How are you extracting your data for analysis?

SPSS

From; CSV - EXCEL - SPSS

Seems you did not get my question.

Have you examined the csv? Is the value missing there as well?

Naa,

Since those questions that their answers disappears are relevant, the whole form cannot be saved as finalized to be uploaded on to the server.

This has happened for how many forms? Have you tried re-entering a new form and the same behavior happened again?

It is very likely that the data was not entered properly.

This has happened to 5 forms.
Whenever I tried to enter a new form, some affected questions will appear and other questions that were not affected now becomes affected.

1 Like

Is it possible that your questions are grouped together on the same screen and they depend on each other? See https://docs.opendatakit.org/form-question-types/#grouping-multiple-widgets-on-the-same-screen for more.

A post was split to a new topic: Randomized the order of appearance