No space available on server

Good day ODK family,
How do we solve this. The root space is full and no available space. Initially the ODK installed within root. Now the users are failing to log in and when I tried to run this command docker exec -it service sh under Central , I am failing because the is no space to run the command and reboot. So, which files should I delete so that will restore some memories. We want to create unused memory so that we can run the command, remove tmp files and reboot using command . Any help on this
ODK issues2

Hi @ChamisaShaps

I encourage you to search the forum thoroughly you can find answers already exist.

For storage issues, check out this Running out of storage on my ODK Central server


You'll need to free up space on your host before you can run any command. Maybe remove unused dependencies and clean up your apt cache with sudo apt-get autoremove; sudo apt-get clean. You can also try temporarily disabling and removing swap or removing everything in /tmp on your host.

This scenario is why we strongly recommend creating an alert for disk use...

1 Like

Thank you so much @yanokwa and @dicksonsamwel for the ideas. @yanokwa your cache cleaning commands failed to run again, while I solved the problem by removing some large log files. When I removed the log files, a small amount of available space was created, which allowed me to run all the commands I wanted to run previously.
Thank you again @yanokwa for addressing this issue in the most recent ODK central version.

1 Like