ODK Aggregate Installation Error when updating app engine

What is the problem? Please be detailed.
I am installing ODK Aggregate using Google Cloud but Am not successful. I am already at the point of ODK Aggregate App Engine Updater -

What ODK tool and version are you using? And on what device and operating system version?
ODK Aggregate v1.4.15 windows-installer under Windows 10 Profesional

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
I get the following output message when updating the app engine:

getToken!: Aug 29, 2017 6:29:39 AM com.google.appengine.repackaged.com.google.api.client.extensions.java6.auth.oauth2.FileCredentialStore
getToken!: WARNING: unable to change file permissions for everybody: C:\Users\PC.appcfg_oauth2_tokens_java
getToken : The following URL can be used to authenticate:

(... removed portions of log here since it contains links....)

getToken : Attempting to open it in your browser now.
getToken : Please enter code:
getToken : Reading application configuration data...
getToken!: Aug 29, 2017 6:30:00 AM com.google.apphosting.utils.config.IndexesXmlReader readConfigXml
getToken!: INFO: Successfully processed ./LegacyRemoval\WEB-INF/datastore-indexes.xml
getToken :
getToken :
getToken : Beginning interaction for module default...
getToken!: Aug 29, 2017 6:30:02 AM com.google.appengine.tools.admin.AbstractServerConnection send1
getToken!: WARNING: Error posting to URL: https://appengine.google.com/api/appversion/getresourcelimits?app_id=BudgetSurvey2017&version=1&
getToken!: 400 Bad Request
getToken!: Client Error (400)The request is invalid for an unspecified reason.
getToken!: This is try #0

(... removed portions of log here since it contains links....)

getToken!: This is try #3
getToken : Unable to get resource limits: Error posting to URL: https://appengine.google.com/api/appversion/getresourcelimits?app_id=BudgetSurvey2017&version=1&
getToken : 400 Bad Request
getToken : Client Error (400)The request is invalid for an unspecified reason.
getToken :
getToken : Please see the logs [C:\Users\PC\AppData\Local\Temp\appcfg6808506040069529795.log] for further information.
getToken :
status : Action failed or aborted by user

Thank you for your help.

Hi Chinx,

do you changed your security level in your google app engine

check this link


before you upload ODK to google app engine log out from your google account.

Best Regards

Hi Nader,

Thanks for your reply.

I have done per your suggestion but I still got the same error message.


Hi Chinx,

try this :


Best Regards

HI Nader,

I am actually following the instructions in that page to setup. I got stuck on step 16. I get a different error message though (as indicated on the first/original post). What I did differently though is using a server in Asia instead of US in step 10.

Thanks again Nader.

All the best!

HI Chinx,

uninstalled the uploader then re-installed and at the project ID type your project ID
with small case all of them.

Best Regards

Hi Nader!

I am able to proceed now to Upload the ODK Aggregate!

Thanks very much! Now proceeding... with the installation...

Again, thank you very very much...

All the best!

You are welcome,

Best Regards

Is it ODK or Google that causes this to be required?

Hi Adam,
i think not ODK, also not google
it is java.

when we load aggregate to google it extract all files and then add to this files information which we enter it within installation process in addition to the permissions which google also needed to grant the application scope of security after that google recompile the files again.

in fact if you have android studio 2.3 you will see the splash screen

and in version 3.0

google give us a message for using low case when we developing in java platform

Best Regards

I'm not sure project ID has to be lowercase, but it wouldn't surprise me if it was. It seems safe to tell people to make it lowercase.

Either way, I don't think the Android Studio rebrand has anything to do with that.

1 Like

in fact maybe you are right Yanokwa,

but i had a lot issues because of letters

specially with Java.

Best Regards

i had same error before. this step solved it

1 Like

A post was split to a new topic: Receiving error on Aggregate

I can also confirm that you must use all small letters, no caps, when specifying the project name.

boa noite, consegui passar na primeira faze de instalação depois de incluir o codigo porem no momento da etapa do upload do odk aggregate esta dando o erro... não sei mais oq houve...

status : Action failed or aborted by user