ODK Briefcase 1.17.0 not opening

1. What is the problem? Be very detailed.

ODK Briefcase is not opening for me as of today. I had been using it without any problems for the past few weeks whilst in the field, for pulling and exporting encrypted data.

2. What app or server are you using and on what device and operating system? Include version numbers.

I'm using ODK Briefcase v1.17.0 on a laptop (using Windows 10).

3. What you have you tried to fix the problem?

I have tried uninstalling and re-downloading the software from https://github.com/opendatakit/briefcase/releases. The same issue is occurring, however. The icon is unresponsive whether I double-click, or right-click and select 'Open'.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

I attach the log in case that might help.
ODK Briefcase Log 16.11.2019.docx (13.2 KB)

Thank you so much for the support, it will be much appreciated!

Hi @pjames

looks as if there is a problem when your forms are being read. Could you make a copy of your ODK Briefcase Storage (to be safe) and then remove the files from ODK Briefcase Storage/forms, and try to open the app. If it works please try to copy back your forms to ODK Briefcase Storage/forms one by one to figure out which file causes the problem.

I'm pretty sure one of your forms is broken, anyway ODK Briefcase should catch it, I'll report this bug. Let me know if I'm right.


Thank you so much @Grzesiek2010.

What you suggested worked perfectly. The problem was an old version of one of the forms which was not being read properly. After that was deleted from ODK Briefcase Storage/forms I was able to open the software again.

With today being the last day of field practice and our proper survey starting tomorrow, you have brought a lot of relief, thank you!