ODK Briefcase Push Getting Stuck

1. What is the problem? Be very detailed.

I recently did an update from Aggregate 1.7.1 to 2.0.3. I used Briefcase to pull all the submission 1.16.3, 662 submissions across 2 forms. When i try to push them to aggregate, they keep getting stuck. Even the ones that have been submitted are not showing up in aggregate. Is it a Briefcase or Aggregate issue?

2. What app or server are you using and on what device and operating system? Include version numbers.

Aggregate - 2.0.3 (Tomcat), Briefcase - 1.16.3, OS - Windows 10, DB - Postgresql 11.

3. What you have you tried to fix the problem?
I tried pushing them one by one but still the same.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

So I sorted out the issue. It seems to be a Briefcase 1.16.3 problem. I downloaded 1.16 and all the forms were sent with no problems.

Hi, @ChipoHankumbaMuleya! Sorry you've been experiencing this issue. In v1.16.3 we adapted to some auth changes in ODK Central and broke integration with Aggregate by accident. We tracked the issue here and we will ship v1.17 in the following days with a fix to make it work for both Central and Aggregate again. Sorry!

Hi @ggalmazor. I'm glad you've acknowledged the issue with v1.16.3. I will try the fix (v1.17) when it comes out. Thanks.

Thanks, @ChipoHankumbaMuleya! In fact, it would help us if you could try the beta release to verify that the issue has been solved :wink:

You can get the beta here: ODK Briefcase v1.17 Beta