ODK Briefcase v1.11 Beta

We need your help to ship great software, so please download this beta, try it, and report the issues you find. The release will be delayed until all reported issues with the beta are fixed.

For everyone who uses Briefcase, the important changes to verify are:

  • Changes to the pull and push user interface work as you expect
  • Can pull a blank form from the computer and push it to the server (replaces FormUploader)
  • Export, especially of large numbers of submissions is not slower
  • On the command line, your push only uploads the blank form if the form is not on the server

If you have a bit more time, please also verify the other changes in the release notes. Again, this beta will be released on Monday unless you report issues below.

Download beta


it gets stuck on "Pulling from aggregate Server" after connect.
I tried connected as admin with one form on the server without submissions and one with submissions.

Tested with:

Aggregate v1.4.13 Production

1 Like

Hi @aurdipas

thanks for testing! I shared your report with our QAs who are in the middle of testing the newest version but it's not completely clear for them. Could you provide more info?

Might it be this already noticed issue?
https://github.com/opendatakit/briefcase/issues/491 or https://github.com/opendatakit/briefcase/issues/481


Hi @Grzesiek2010, what happens is that after I click connect I've the following screen. Pulling data but empty list.

Could you try to reset your connection and log in again, If it helps it's the same issue.

I tried several times.

Hi, @aurdipas! Thanks for testing the beta! Your feedback is very valuable!

We have been able to reproduce your problem under certain conditions:

  • The setting "Remember passwords" is unchecked in the Settings Panel
  • The user configures an Aggregate server entering correct connection params and closes Briefcase
  • The user gets an empty list when launching Briefcase again

Is this what happened in your case?

Could you follow these instructions and report back what happens, please?

  • Click on reset.
  • Ensure the "Remember passwords" setting is checked on the Settings tab
  • Configure an aggregate server on the pull tab. You can use https://opendatakit.appspot.com
  • Verify that you can pull a form
  • Close Briefcase
  • Open Briefcase
  • Verify that the form list is not empty
1 Like

Hi @ggalmazor

I have tried the steps on my windows pc, i noticed the following:

  1. I was successful in connecting and pulling some submission.
  2. When i closed the briefcase program, i couldn't re-launch it on double clicking. When i used the cmd, i got the following

While the 1.8.0 works properly, that is the version am using.
My pc has java version 1.8.0_161


1 Like

Thank you for reporting, @dicksonsamwel! It looks like the same issue @kkrawczyk123 was running into at https://github.com/opendatakit/briefcase/issues/498 but that we were having trouble reproducing.

1 Like

Not excactly my condition:

  1. Downloaded the beta
  2. I open it for the 1st time
  3. configure the settings (storage location, pull in parallel, remember password)
  4. Configure server on the pull tab and connect.

Stuck on pulling then and empty list.
I tried to reset, close and restart, change the folder etc etc. Nothing change.

Java version "1.8.0_172"
Windows 7 enterprise Service pack 1

Hi, @aurdipas!

To isolate the source of your problem, could you use this Aggregate server instead and try again, please?

URL: https://gigiaggregate.appspot.com
username: administrator
password: aggregate

Also, could you copy here the briefcase.log file? It's often located in at the same place in your hard disk you start Briefcase from.


Hi, @dicksonsamwel! Thanks for reporting that error.

I've analysed the stacktrace and it points to a duplicate form in your storage directory. Did you manually copy or move forms in your storage directory, by any chance?

It works with your instance on appspot but I'm using a v1.4.13 Production Aggregate on my local server with tomcat 8.
I don't have any briefcase.log file on in the folder where the jar is. I see a .briefcase-javarosa.log that was created in other folders where I had the previous release.
But it is not the one for the beta.

Thanks, @aurdipas!

Let's try to get the logs. I'm attaching to this comment a log config file I'd like you to use when trying to access your Aggregate 1.4.13 local server.

logback.xml (282 Bytes)

Place that somewhere in your hard disk and run Briefcase using this command:

java -Dlogback.configurationFile=PATH_TO_THE_logback.xml_FILE -jar PATH_TO_BRIEFCASE_JAR_FILE

That way, you will any error log lines on your console.

I think something wrong with the logging already :slight_smile:

Hi, @aurdipas! I've veryfied on a win10 with the same JVM you're using that the logback conf I attached should work.

I've seen, though, that the arg after the -D should be quoted like this: java -D"logback.configurationFile=logback.xml" -jar .\ODK-Briefcase-v1.11.0-beta.0.jar

Try leaving the logback.xml file in the same folder as the Briefcase JAR file.

nothing to do... nothing in the log and still empty list and same message "pulling from Aggregate server"

tried to clean the registry and with 2 other different ODK Aggregate instances (1.4.14 and 1.5)... same results!!! :frowning:

Something strange is going on here. @aurdipas and @ggalmazor, I think you might be in the same time zone. Might be easier to escalate to a quick Skype call?

@yanokwa I'm still in Singapore this week.
@ggalmazor I tried from another windows laptop (win 7 and Java 8) and same issue.
I'll send you a pm with the credentials of my test server. It could be related somehow to my aggregate on Tomcat?

1 Like