ODK Briefcase v1.11 Beta

Hi, @aurdipas, @yanokwa! I've just created a PR that solves the issue Aurelio was having. It turns out that Tomcats are somewhat more sensible than AppEngine with duped HTTP headers.


Thanks to everyone (especially @aurdipas and @dicksonsamwel) for testing this release so well! We've fixed the reported bugs (and a few unreported ones) and uploaded a new beta.

Please download the updated beta (v1.11.0-beta.1) and give this build a try!

We'll wait a few more days for your feedback and aim for releasing a final build on Monday.

Hi @yanokwa, I'm trying to use Briefcase to upload a form. I've myform.xml and in the same folder where the form is, I created a folder myfolder-media with a csv inside.
Tell me if I'm doing wrong. I pull the form definition and then I try to push it to aggregate.
The form is successfully uploaded but with no media.

Do I miss something?


I am not able to reproduce this problem with Briefcase v1.11.0-beta.1.

I started with a form accents.xml with accents-media folder with test.csv inside. That form was on my desktop and pulled it into Briefcase and confirmed that the XML and CSV were in the Briefcase storage directory. Then I pushed it to Aggregate v1.5.0 on GAE that did not have the form and confirmed that both the XML and CSV were on the server.

Here is the relevant part of my briefcase.log. Can you share yours?

2018-06-15 13:34:56,805 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Reading XML and parsing with kXML2 finished in 3.936 ms
2018-06-15 13:34:56,808 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Consolidating text finished in 0.867 ms
2018-06-15 13:34:56,809 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Parsing form...
2018-06-15 13:34:56,809 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Title: "accents"
2018-06-15 13:34:56,823 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Creating FormDef from parsed XML finished in 14.171 ms
2018-06-15 13:34:59,593 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Reading XML and parsing with kXML2 finished in 0.746 ms
2018-06-15 13:34:59,594 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Consolidating text finished in 0.261 ms
2018-06-15 13:34:59,594 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Parsing form...
2018-06-15 13:34:59,594 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Title: "accents"
2018-06-15 13:34:59,595 [AWT-EventQueue-0] INFO  org.javarosa.xform.parse.XFormParser - Creating FormDef from parsed XML finished in 1.595 ms
2018-06-15 13:35:15,732 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Parsing URL https://nafundi-test.appspot.com/formUpload
2018-06-15 13:35:15,746 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - added form_def_file: accents.xml
2018-06-15 13:35:15,746 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Trying file /Users/yanokwa/Downloads/ODK Briefcase Storage/forms/accents/accents-media/test.csv
2018-06-15 13:35:15,746 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - added csv file test.csv
2018-06-15 13:35:15,749 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Attempting URI https://nafundi-test.appspot.com/formUpload
2018-06-15 13:35:20,452 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Redirection to URI https://nafundi-test.appspot.com/formUpload
2018-06-15 13:35:20,453 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Parsing URL https://nafundi-test.appspot.com/submission
2018-06-15 13:35:20,454 [pool-2-thread-1] INFO  o.o.briefcase.util.FileSystemUtils - Creating database directory /Users/yanokwa/Downloads/ODK Briefcase Storage/forms/accents/info.hsqldb
2018-06-15 13:35:20,834 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Parsing URL https://nafundi-test.appspot.com/view/submissionList?formId=accents&cursor=&numEntries=100
2018-06-15 13:35:20,835 [pool-2-thread-1] INFO  o.o.briefcase.util.AggregateUtils - Attempting URI https://nafundi-test.appspot.com/view/submissionList?formId=accents&cursor=&numEntries=100

Did the form already exist on the server?

Hi @ggalmazor,

I did not copy or move the the forms. I used an existing storage directory, which i use in pulling data occasionally.

With the updated beta version, i was still getting the same error as reported, while using existing storage directory created by "1.8.0". But after setting a new storage directory, the error disappeared, and successfully followed the instruction, and i confirm form list was not empty.

1 Like

I have tested the form upload aswell with the new release, i successfully pulled a form from aggregate one, with media, then pushed the same form to aggregate two. The form with submissions uploaded successfully.

But i have noticed a strange behavior when i manually copy a form with submission, with an intention of pushing it to another aggregate.

With the newly created storage directory, i copied a form , from my previous downloads. After relaunching the briefcase, the form doesn't appear. Hence cant push, even after pressing the reset button. But with previous versions, the form appear and can push it, that is with (1.8.0)

Java version (My Laptop)
java version "1.8.0_161"
Java(TM) SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)

Aggregate version: v1.4.9


1 Like

I re-configured briefcase storage directory and started from a clean condition.
Tested again and it works.


1 Like

Thanks for your feedback, @dicksonsamwel! The tip @aurdipas has given is a good workaround. Another thing you could do is to remove the cache.ser file inside the storage dir. That would force a rebuild of the cache which would make your new form appear on those lists.

We don't support that kind of manual manipulation of the storage directory out of the box yet. I know that previous versions were maybe less picky about it but we've discovered that they can make Briefcase unstable long-term and we're trying to be more restrictive moving forward.

At the same time, we're progressively adding more features to let users avoid having to manually manipulate the storage directory. One example of that is that now you can pull an individual form from your computer into Briefcase. I can see a new tab in the near future focused on form management tools like adding encryption, removing, adding and modifying forms, merging submissions... new stuff that would replace manual manipulation with safe, controlled Briefcase operations.


We've shipped the production version at ODK Briefcase v1.11.

@aurdipas and @dicksonsamwel, thanks again. Your great feedback earned you Tester badges!

@dicksonsamwel, we're trying to understand why you got that error about duplicate keys when you tried the beta and we are wondering why you would manually manipulate the storage dir in the first place. Would you care to explain, please? That would probably give us some insights about the problem and possible solutions.

1 Like

I got the the duplicate error when I used existing odk storage. I use briefcase on my daily basis to pull submissions. So while testing the beta, I used the same directory, created by 1.8.0. That is how I got the errors. Am yet to try the new releases.
Conserning manually manipulating the odk storage, I was testing the push function, so I had a form pulled from other odk instance, then tried to push it. Refer my earlier thread, I explained more.


Thanks for your feedback, @dicksonsamwel!

1 Like

A post was split to a new topic: Briefcase v1.11 too slow