ODK Central Installation Unreachable

1. What is the issue? Please be detailed.

I've recently installed ODK Central on a Ubuntu 22.04 VPS server, routed DNS odk.c4ed.org record to server IP, services seem to be running at VPS but ODK Central admin page is not loading.

2. What steps can we take to reproduce this issue?

Pls see screenshots for details:

4. Upload any forms or screenshots you can share publicly below.

A post was split to a new topic: Docker build failing

What do your nginx and service logs say. See https://docs.getodk.org/central-troubleshooting/#reading-container-logs for how to check.

Hi Yaw, thanks for the reply, pls see attached docker logs

This looks like a network or DNS issue. Is Central the only thing running on the server? Do you have any upstream network firewall or proxy? What do your nginx logs say?

Yaw, yes currently only ODK Central is running on the server, below are the nginx logs from sudo docker-compose logs nginx

These were rather long so attaching text file:

nginx_logs.txt (70.0 KB)

I just tried with below terminal commands:

docker compose stop;
docker compose rm nginx -v;
docker compose build;
docker compose up -d;

It seemed to work, now I can reach and login within ODK Central, however not sure how that worked as when .env file was updated with relevant URL information I believe build was executed after then, also attached are updated nginx logs for your review, is there any action required for the "warnings" at the top?

Thank you so much!

nginx_logs_2.txt (84.3 KB)

Should I be concerned about this line:

central-nginx-1       | 2023/11/27 11:10:40 [error] Important file(s) for '/etc/nginx/conf.d/odk.conf' are missing, disabling...
central-nginx-1       | This certificate expires on 2024-02-25.
central-nginx-1       | These files will be updated when the certificate renews.
central-nginx-1       | NEXT STEPS:
central-nginx-1       | - The certificate will need to be renewed before it expires. 
central-nginx-1       | 2023/11/27 11:10:40 [error] Important file(s) for 
Certbot can automatically renew the certificate in the background, but you may need to take steps to enable that functionality. See https://certbot.org/renewal-setup

My guess is that you installed over an old version of Central without following the upgrade directions. Regardless, removing the nginx container as you did is a fine solution.

You can ignore the warnings. They are from before the SSL certificates were requested and successfully installed.

1 Like