ODK Collect v1.27.3 is popping this error: no such colum: geometryType(code 1) whenever you click on the form

1. What is the problem? Be very detailed. <no such column: geometryType(code 1):, while compiling: SELECT canEditWhenComplete, deletedDate, status, jrVersion, jrFormld, geometryType, instanceFilePath, date, submissionUri, geometry, displayName, _id FROM instances WHERE ((status=? or status=?)) ORDER BY displayName ASC>

2. What app or server are you using and on what device and operating system? Include version numbers. <app: ODK Collect v1.27.3 server:https://kc.humanitarianresponse.info/lmh_rmel. Custom build version: It's being used on BLU_S590Q_v6.0.04_GENERIC 12-07-2018 11:10 android 6.0>

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hey @Washington_Gbowoe :wave:. Welcome to the forum. If you get a moment, pop on over and introduce yourself here.

Does this error appear as soon as you open the app?

Also, did you install Collect 1.27.3 fresh or update it from another version of Collect? If so, which version?

@seadowg, thanks for replying!

"Does this error appear as soon as you open the app"? Yes!

"Also, did you install Collect 1.27.3 fresh or update it from another version of Collect? If so, which version"? I was installed fresh from google play store.

I hope you help me out

Could you perhaps have previously installed a clone of ODK Collect such as Kobo Collect?

1 Like

@LN, for this device, only the ODK Collect v1.27.3 is installed

So you have never used any other app which is based on ODK Collect on that device? We are asking because we want to track down the cause but I guess we did a lot to deal with such errors but sometimes something just goes wrong during upgrading databases.
Here is similar topic Error Code: 1 (SQLITE_ERROR)
@Washington_Gbowoe if you want we can solve your issue in the same way like there (share the same file with me in private).

Or if it was a fresh install and you don't have any saved forms you can just remove that (instance.db) file and open the app again. It should work as well. Vut be carefull and do that only if you don't have any saved data.

1 Like

@Grzesiek2010, initially, we installed a customized app ( Liberia ODK) which is similar to ODK Collect.

It's similar to the problem from my end

Ahh that probably caused the issue. Theoretically it should work well on the same device with the original app but since ODK Collect and its forks share the same folder, if you used different databases/database versions then collect might not be able to perform its own migrations on databases. So yeah in this case the only solution is what I described above.

1 Like