ODK new form upload issue

When I am going to upload my new form then its show a problem which is show as following.

HTTP Status 400 – Bad Request
Type Status Report

Message Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?

Description The server cannot or will not process the request due to something that is perceived to be a client error (e.g., malformed request syntax, invalid request message framing, or deceptive request routing).

Apache Tomcat/8.5.14 (Debian)

1. What is the problem? Be very detailed.

2. What app or server are you using and on what device and operating system? Include version numbers.

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Good morning @Md_Saedur_Rahman and welcome to the ODK Community forum.

When you get a chance, please take some time to introduce yourself here :slight_smile:

How did you proceed to generate your XForm xml file ?
Did you sent an xml file to Aggregate ?

Good Evening @mathieubossaert and thanks to reply me.
First I try to generate XForms xml file by using "ODK-XLSForm-Offline-Windows-v2.0.0". Then I try to aggregate this form to ODK server but its show me these error. I also try to generate xml by online ODK but they did not find any warning or error.

Did you already succeed on your server with other forms ?
What is your aggregate's version ?

1 Like

Good morning @mathieubossaert. I already succeed with other form earlier. but when I am getting these problem then again I am trying to upload with my old version form but I getting same problem. I am using v2.0.0 aggregate.

good morning @Md_Saedur_Rahman,

could you share your xls file ? Or is it sensitive ?

Please share with me your mail ID. it is sensitive so I can't share it within forum.

I can reproduce it, form is ok in Central and preview it in enketo, but I got this warning :

When trying to upload the downloaded xml from Central on Aggregate 2.0 server I get the same error as you :

Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?

I succeeded using xlsform v1 :wink:

Thank you so much. Now its ok.

1 Like