Problem with Geotrace or Problem with Briefcase?

Hi everyone
1. What is the problem? Be very detailed.

I have a form that has been used for a long time. Since one of the last updates to ODK-Collect, the export no longer works properly. When I export with Briefcase, all data records are output to me as .csv. But not when exporting the Geojson.

There was a change in the form. Due to the changes in ODK-Collect ("repeat function") I had to include an additional question (marked yellow in RADINF.xlsx). So that I don't get into the repeat loop, unless of course I need it.

I can't explain the export behavior (Geojson) about this.
Is the Problem my Form or ODK-Briefcase or ...?

I've tried a lot, but I don't see any pattern either. Some data records are displayed in the GEojson, others are not available (examples for RADINF.csv and .geojson are attached)

RADINF.xlsx (34.3 KB) RADINF.xlsx (34.3 KB) RADINF.csv (363.9 KB) RADINF-Wiederholung.csv (175.3 KB) (73.9 KB)
2. What app or server are you using and on what device and operating system? Include version numbers.
ODK-Collect - PC - ODK Briefcase (Collect directory)
3. What you have you tried to fix the problem?
With WordPad I could change the wkt from the .csv to an qGIS compatible Format. I have now the my Geodata. But it would be better if it do this from the Export from Briefcase.
For the search
4. What steps can we take to reproduce the problem?
For troubleshooting, I have merged the RADINF.csv and the Geojson table in an Excel file and used a formula to check which data appear in both files and which only in the csv.
The table is attached here.
Checking RADINF.xlsx (393.3 KB)
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
I hope that someone can help