Problem with Trees Registration Example "The XLSForm could not be converted: 'dataset'"


I feel like I must be doing something silly, but I can't seem to get the Tree Registration form to upload to our ODK Central server. Every time I try to upload the form I get the following message (The XLSForm could not be converted: 'dataset').

I saw that someone asked this questions last month, but it was removed so I can't see the solution. I have attached the trees registration form xlsx file that I am using just incase and I would appreciate any help.

Thank you!
trees_registration_entities.xlsx (82.5 KB)

Welcome to the ODK community forum @mscholtens, when you'll get a chance please introduce yourself here :wink:

What is the version of your server ? Is nt young enough to support entities ?

Hi! We are running v2023.3.0, which I believe matches the version used in the tutorial videos. However, an update to v2023.4 wouldn't hurt. Is there anything else that could be causing this?

If you upload this form to the online validator (version October 2, 2023), I got the same error: 'dataset'. (Until you remove/rename the bind column and the entity sheet).

But trying again later, it works well now! So, it might have been a temporay server issue?

Interesting twist to this issue. If I use the online validator with this file and download the xml file, it works and uploads with no error and creates the dataset/entity list. For now that is a decent work around, but it is very strange that the xlsx files are causing an error.

See update above. It works now. Maybe, you can also try again with your server, please?
It seems there was just an update now: Update Online Validator - to allow Entitity feature - #2 by yanokwa.

1 Like

@mscholtens Please update to Central v2023.4 to fix this problem.

1 Like

Thanks for reporting this, @mscholtens. There were a couple of issues:

  • The XLSForm online server is supposed to track the main branch of pyxform but it had stopped updating automatically. That's now been fixed by @yanokwa.
  • In Central v2023.4, we removed the word dataset and replaced it with entity list. We also aliased entity_list to dataset in pyxform and updated our examples. That means those examples won't work with older versions of Central/pyxform. I'll update them to make a note about that. In general, we do recommend upgrading soon after Central releases if possible. In this case you can also just use dataset as the column name. That will continue to work in future versions of Central as well.