Select Multiple from file doesn't allow map appearance

1. What is the issue? Please be detailed.

Hi All, is this a bug? Attached are 2 identical Excel files. The select-one allows map selection from the associated CSV file. The select-multiple will just display all the options as a list in the form.
Currently using Google Drive, but am setting up a Central Server (would this make a difference?)

ALSO: will there ever be an option to create a new WPT on the same map? I want the selection of a survey site to be Required, but i can't do this if the survey is being done at a new site and that site has to be mapped as a new question. Fussy much.

I want to use an external file because i want it to link to multiple forms for our different research projects and not have to edit the Choices tab of multiple forms each time it changes.

2. What steps can we take to reproduce this issue?

Upload the 2 form fragments and associated csv
SelectOne.xlsx (108.3 KB)
SelectMulti.xlsx (108.3 KB)
AllWaypoints.csv (1.7 KB)

3. What have you tried to fix the issue?

crying hasn't worked so i'm all out of ideas... :grinning:

4. Upload any forms or screenshots you can share publicly below.


select_multiple does not work with the map appearance. The map appearance has been implemented recently and only for select_one questions. In the future, it might be added but there are no clear plans for when.

could you elaborate on that? I'm not sure if I understand what you want to achieve.