SMTP Error: Missing credentials for "LOGIN"

1. What is the problem? Be very detailed.
According to Installing Central on DigitalOcean — ODK Docs, I've tried to change my SMTP settings to:

    "email": {
      "serviceAccount": "no-reply@MY-DOMAIN.com",
      "transport": "smtp",
      "transportOpts": {
        "host": "smtp.office365.com",
        "port": 587,
        "auth": {
          "user": "no-reply@MY-DOMAIN.com",
          "password": "MY-PASSWORD"
        }
      }
    },

The SMTP account requires auth, STARTTLS, but not SSL.

The the logs this error is shown:

service               | Error: Missing credentials for "LOGIN"
service               |     at SMTPConnection._formatError (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:591:19)
service               |     at SMTPConnection.login (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:340:38)
service               |     at /usr/odk/node_modules/nodemailer/lib/smtp-transport/index.js:270:32
service               |     at SMTPConnection.<anonymous> (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:188:17)
service               |     at Object.onceWrapper (events.js:291:20)
service               |     at SMTPConnection.emit (events.js:203:13)
service               |     at SMTPConnection.EventEmitter.emit (domain.js:494:23)
service               |     at SMTPConnection._actionEHLO (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:1113:14)
service               |     at SMTPConnection._processResponse (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:747:20)
service               |     at SMTPConnection._onData (/usr/odk/node_modules/nodemailer/lib/smtp-connection/index.js:543:14) {
service               |   code: 'EAUTH',
service               |   command: 'API'

2. What app or server are you using and on what device and operating system? Include version numbers.

versions:
647569c54f6bbf26ea356eca0d14f7e5d1a89c6b
 cddb691e40e84aabff87b9d427e22a50282d6f99 client (v1.1.2)
 a33bc6fb3c34fe38894b0e9d0bb404f81da325e6 server (v1.1.1)

3. What you have you tried to fix the problem?
Set secure to true, false and remove it completely as suggested here

4. What steps can we take to reproduce the problem?
Maybe it's hard unless you have an office365 account...

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

The auth key is pass not password.

1 Like

:man_facepalming: I've checked everything 5 times, but didn't saw that... Sorry and thank you!