Something went wrong: the server returned an invalid error after custom mail server setting

1. What is the problem? Be very detailed.
I am setting up ODK Central using Digital Ocean and successfully installed everything. Now i successfully tried to configure custom mail server as per [document ]. But after this step i am not able to log into server and it shows "Something went wrong: the server returned an invalid error."
2. What app or server are you using and on what device and operating system? Include version numbers.
Using Docker 19.03.12 on Ubuntu 20.04
What steps i m missing to configure custom mail server

Try to look to following posts:

Hi aurdipas
Thanks for the two posts. But still I haven't able to get the solution.

  1. Followed all steps to install Central using digital ocean
  2. Followed Custom Mail server step to setup my mail server credentials
    What exactly I am missing ?

The "Something went wrong: the server returned an invalid error" suggests that when you changed the email configuration, you did not follow the format exactly and you are missing a comma or used password instead of pass or something like that.

Run docker-compose logs service and see if it gives you any clues as to what is going wrong.

Dear yanokwa
I agree that there's something which I am missing in files/service/config.json.template. Please go through attached screen shot and suggests me what I am missing.

The docs at https://docs.getodk.org/central-install-digital-ocean/#using-a-custom-mail-server show secure and auth variables. Is there a reason you did not include those? It’s unlikely that you don’t require auth on your SMTP server.

Thanks yanokwa for guiding me. Now I am able to log into the central. But now I am not able to reset password as it give "Something went wrong: the server returned an invalid error." while trying resetting password. My mail credentials are working and I am able to send /receive mails from that email id. What I am missing now.

This is an issue with your mail credentials, port, or the secure flag. If you are sure the credentials are correct, try changing the secure flag first and see if that helps.