Sending Forms Error 'Could not find resource you are looking for'

1. What is the problem? Be very detailed.
Upon trying to submit 1 of 4 forms I receive the following error " Error: Generic Exception: Error: Could not find the resource you were looking for" A seperate form on the same server and project works perfectly fine. On other servers using the same form I have not encountered this issue.

2. What app or server are you using and on what device and operating system? Include version numbers.
Using a .getodk.cloud server and currently running ODK collect v 2022.1.1 on a Samsung A7

3. What you have you tried to fix the problem?
I have tried reconnecting to the internet. Double-checking the server address. I have also tried reuploading the form and testing a submission, all works fine. I have also renamed the form_id.

4. What steps can we take to reproduce the problem?
This happens every time I finish a form and try to submit it. The form automatically saves under 'Send Finalised Form'

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach them below.

Typically, you get this error when the form you are submitting has been disabled (e.g., form goes from draft to published or a form has been closed). That doesn't seem to be the case here, so more investigation is needed.

Since you are on ODK Cloud, I've sent you a direct email so I can provide more hands-on support. I'll post my findings to this forum topic once the issue is resolved so others can benefit.