Enketo says "Could not connect with Server" on preview request

1. What is the problem? Be very detailed.
Preview of form is not available, as soon as I uploaded a new form successfully, i wait few seconds for the preview button to become available. I click the preview button then I'm redirected to enketo and I get:
"Loading Error", "Could not connect with Server"

I installed the default installation as described in the documentation using docker-compose (docker-compose version 1.25.5, build 8a1c60f6). Everything is running with the default configuration. My .env is:

SSL_TYPE=selfsign
DOMAIN=localhost
SYSADMIN_EMAIL=administrator@email.com

2. What app or server are you using and on what device and operating system? Include version numbers.
no other service is running, i'm running centos 7 and mint (tried on two machines)

3. What you have you tried to fix the problem?
Tried to install on two different machine. I looked into the nginx logs
4. What steps can we take to reproduce the problem?
Just follow the documentation install steps, create a admin user, upload a form and click on preview.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

This is the nginx log showing the 500 error last:

192.168.11.101 - - [10/Dec/2020:18:08:31 +0000] "POST /-/transform/xform/ZAW8h45RDZA9DPh1GFwOE9HR6GqQ2f4 HTTP/1.1" 500 67 "https://192.168.11.13/-/preview/ZAW8h45RDZA9DPh1GFwOE9HR6GqQ2f4" "Mozilla/5.0 (X11; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0"

I also tried scanning the QR code on the collect app but I cannot see the empty form.

1 Like

Same problem, did you found solution?

@KonstantinosKr

To resolve this problem, first identify your upstream DNS servers.

Check this topic https://docs.getodk.org/central-troubleshooting/

1 Like

Thanks,

but problem still exist after your suggestion.

Have the same problem.
The DNS works perfectly OK(I have the page running, set up users and projects and uploaded a form from formBuilder), how could doctoring DNS solve anything?

Neither Enketo nor Collect will work with self-signed certificates. See Central/Enketo integration with self-signed cert - #2 by LN for more.

You also need to make sure you have disabled any firewall you have configured.

@Hartmut_Noack if neither of those ideas help, please make sure you have fully read and understood the section shared by @rassam.

1 Like

3 posts were merged into an existing topic: Enketo says Could not connect to server

A post was split to a new topic: After upgrading to Central 1.2, Enketo previews work for some forms but not others