GPS accuracy cannot go beyond 10m

What is the problem? Please be detailed.
Hi everyone,

I am having issue with GPS accuracy when taking geopoint. The accuracy cannot reach the lower than 10 meter. It used to be working fine and could reach 2 to 5 meter accuracy.

What ODK tool and version are you using? And on what device and operating system version?
I'm using ODK collect 1.13.2,with Samsung sm-p355 (Android 5.0.2) and LG G5 (Android 7.0).

What steps can we take to reproduce the problem?
Taking geopoint field.

What you have you tried to fix the problem?
Restart the phone not solving the issue.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Please, if there is something I'm missing?

Thank you

@Jerry_Quarry_Mentang ,
Please go through with my slide, which is here( and also make sure that when you are taking GPS your phone should be in flight mode.


@iamnarendrasingh, Thank you for your advise. I follow your instruction, but still not working.I'm also using similar app which is GPS Status & toolbox. Usually I don't need to use additional app for ODK.

@Jerry_Quarry_Mentang Thanks for taking the time to report this. It sounds like you are having similar problems with both devices? The code that governs GPS capture has not changed for a few months. Do you have any idea when this issue started or on what Collect version? Are you in the same physical location as when you were getting higher accuracy readings?

Does the GPS status app report a higher accuracy than Collect does?

What are your location settings at the Android level set to? Here's how to see them on some devices:; on my device it's Privacy > Location. If you change it, do you see any change in behavior?

1 Like

Hi @LN
Thank you for your reply.

After I tested with older version of ODK Collect. The issue start to show beginning from 1.11.0 to current version. When I use 1.10.0, the devices can quickly reach 5m threshold.

I tested version 1.11.0 and 1.10.2 on both devices, on the same location. 1.10.2 can get to 5m but 1.11.0 stop at 10m.

GPS status reported accuracy up to 3m.

Location settings set to high accuracy on G5 and GPS, Wi-Fi and mobile network on Samsung SM-P355.
I changed to different settings, the issue still exists.

Also my colleague on different location reporting the same issue using Xiaomi Redmi 4 Prime and Xiaomi Redmi 4A.


1 Like

Thanks very much for all that very useful information. What versions of Android do those devices have? You should be able to find that in Settings in the About Phone which is usually at the very bottom.

I've filed an issue at and will report findings and progress here.


This is the devices and it's OS I have tested:

LG G5: 7.0
Samsung Tab A: 5.0.2
Xiaomi Redmi 4 Prime: 7.0
Xiaomi Redmi 4A: 6.0.1

Thank you for your help.


1 Like

Hello all, in the last month i have started to see the same issue among my fleet of ODK data collectors. More than 10 of my users have reported that the GPS will not go below the 10m accuracy while collecting the geo point. We are using the Digicel DL1 and Samsung Note 4 android devices.

Also the ODK briefcase has gotten extremely slow in downloading the collected data, i have tested this across several wifi connections and its the same issue.

I am curious to hear if anyone else is having these issues and if any solutions/fix is available.

Best regards,

@Yohan_Parmanand While we try to track down this problem with Collect, I'm curious why you did not report this issue earlier. Did you not think it was a bug? Did you not know where to report it?

As to the Briefcase issue, let's continue that conversation at ODK briefcase has gotten extremely slow in downloading the collected data.

Hi @yanokwa I initially thought it was an issue with the device that the technicians were using and possibly the area that they were working in. However, last week several other technicians using different devices in a different area reported the same issue. I looked the issue up and came across this forum.


If you are having GPS problems, please try the ODK Collect v1.14 Beta.

@Jerry_Quarry_Mentang and @Yohan_Parmanand, thank you very much for taking the time to provide details on this issue. @Heath623 has also provided useful insights at Infinite spinning while getting location with Bluetooth GPS device. Several contributors have done their own tests and reported back on Slack and @jknightco has also run some experiments.

What I believe after some community discussions and this StackOverflow post is that the more modern Google way to get location information always tries to combine location sources (GPS, wifi ssid, cell network, other Android devices, etc). It appears that when phones/tablets are set to "GPS only" the best accuracy reported is 10m. The GPS accuracy may be better than that but because the Google location mechanism can't use other sources it does not report a better accuracy than 10m. I believe that testers and people like me didn't notice this because we were verifying the behavior in denser urban areas with lots of other available sources that made reported accuracy high. @Jerry_Quarry_Mentang, @Yohan_Parmanand, @Heath623 are you in locations where few other sources of location data would be available? This really highlights the importance of the beta program and getting feedback from a wide range of users!

The Collect beta that @yanokwa mentioned above gets location more slowly than the current release but it should be able to report accuracies under 10m. It would be very helpful if you could try it (on a test device) and make sure that the behavior matches your expectations.

If anyone else has any insights on this issue or their own experiences to report, it would be much appreciated.

Hi @LN and @yanokwa

Thank you for your effort to solve this issue.

In my case, I am using ODK Collect mostly in remote area that have no other GPS sources (Wifi, cell network), we rely on "GPS Only" mode.

I'll test v1.14 Beta and get back to you guys with the result.


We have recently tested the 1.14 Beta and the problem appears to be resolved. We have posted re a separate issue that seems to have reduced the save geopoint button on the offline map view to a small (almost invisible) rectangle.

1 Like